Closed Bug 1023407 Opened 5 years ago Closed 5 years ago

Disable switch-to-new-tab button toast for Fx32

Categories

(Firefox for Android :: General, defect)

32 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox32 --- verified
firefox33 --- unaffected
fennec 32+ ---

People

(Reporter: Margaret, Assigned: nalexander)

References

Details

Attachments

(1 file)

Don't want to ship this feature until all the follow-up bugs are fixed.

Let's just revert this to a normal toast.
This patch should only land on Aurora
Version: Trunk → Firefox 32
The approach I'm going to take is to comment out (with a discussion) the bits that make the toast be a button toast.  That is, this is not a backout; it is a separate Aurora disabling.
Status: NEW → ASSIGNED
Attached patch 1023407.patchSplinter Review
margaret: I reckon you're a reasonable reviewer for this.  Feel free to re-assign.  Tested locally; both in-content and home fragments look good from here.
Attachment #8439488 - Flags: review?(margaret.leibovic)
Comment on attachment 8439488 [details] [diff] [review]
1023407.patch

Review of attachment 8439488 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8439488 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 8439488 [details] [diff] [review]
1023407.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1019735.

User impact if declined: bad experience with new feature: ButtonToasts interact badly with touch events, blocking interaction with the rest of the system until the ButtonToast expires or is otherwise dismissed (Bug 1019735)

Testing completed (on m-c, etc.): built and tested locally.

Risk to taking this patch (and alternatives if risky): low -- basically me making a coding error (but I tested all affected scenarios).  This just replaces a ButtonToast with a system Toast.

String or IDL/UUID changes made by this patch: none!
Attachment #8439488 - Flags: approval-mozilla-aurora?
Attachment #8439488 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Verified as fixed in build 32.0a2 (2014-06-17)
Device: Motorola Raz (Android 4.0.4) and Samsung Galaxy R (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.