Submit button doesn't work after form is reset

VERIFIED INVALID

Status

()

Core
HTML: Form Submission
--
critical
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: J Luh, Assigned: rods (gone))

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
With Mozilla 0.9.4 build 2001092805, the Google Search button doesn't work on
the page indicated. 

To reproduce:

1. Navigate to: http://www.google.com/search?q=mozilla
2. Press "Google Search button."

Should submit the form, but nothing happens.

Works in Mozilla 0.9.4 build 2001092705. I imagine the problem is related to bug
102176, but the symptoms are different.
(Reporter)

Updated

17 years ago
Keywords: regression

Comment 1

17 years ago
Confirming issue under Mac OS X build (2001-09-28-20)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Well I think this actually *is* a dupe of bug 102176....

Google searches are done with method GET.  So your URL is really the same as
going to the google main page, and typing in "mozilla" then submitting once. So
the next time you hit submit, it makes sense that if double submits are broken
so is this.

Marking dupe as bug 102176 has been confirmed to occur on google as well. I'll
comment on that bug about this as well.  Same symptoms just slightly different
method to reproduce.

*** This bug has been marked as a duplicate of 102176 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Christopher Aillon, yes, the URL and the GET form submission are the same from
the server's point of view, but they are not the same from the browser's point
of view. The problem still occurs if you load the page from a local file.

The problem seems to be the onLoad="document.gs.reset()" in the <body> tag; I am
attaching a test case.

I am reopening this bug because sourceforge.net (the site referenced in bug
102176) does not have a reset.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

17 years ago
Created attachment 51448 [details]
test case
(Reporter)

Updated

17 years ago
Summary: Submit button doesn't work on some pages → Submit button doesn't work on page with onLoad="document.formname.reset()"

Comment 5

17 years ago
https://banking.wellsfargo.com/ has the same structure (onLoad with a reset in
the body tag), and it is not working either.

This is on Mozilla trunk build 2001092906 on Linux.
(Reporter)

Comment 6

17 years ago
It looks like this problem affects any form that is reset, whether it's reset
through the onLoad event or through the reset button. Try:

resource:///res/samples/test8.html

Press the reset button in the middle of the page, then press the submit button.
The submit fails.
Summary: Submit button doesn't work on page with onLoad="document.formname.reset()" → Submit button doesn't work after form is reset

Comment 7

17 years ago
I've got the same problem under Windows 2000, build ID 2001092803.

Updated

17 years ago
Severity: major → critical
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Updated

17 years ago
Keywords: nsbranch

Updated

17 years ago
Blocks: 101793
(Assignee)

Comment 8

17 years ago
Created attachment 51540 [details] [diff] [review]
proposed patch
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED

Comment 9

17 years ago
getting on the radar for the branch
Keywords: nsbranch → nsbranch+
Whiteboard: PDT
(Assignee)

Comment 10

17 years ago
The patch causing this problem has been removed - invalid
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 11

17 years ago
*** Bug 102661 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.