Date object is displaying the wrong timezone

RESOLVED DUPLICATE of bug 879261

Status

()

RESOLVED DUPLICATE of bug 879261
4 years ago
3 years ago

People

(Reporter: zevvy2, Unassigned)

Tracking

29 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

create a new Date object



Actual results:

the GMT is listed as GMT-0500 (Eastern Standard Time)
the GMT is listed as GMT-0400 (Eastern Daylight Time)


Expected results:

the GMT is listed as GMT-0500 (Eastern Daylight Time)
the GMT is listed as GMT-0400 (Eastern Standard Time)
Testcase please?

(new Date()).toString() returns "Wed Jun 11 2014 01:07:31 GMT-0400 (EDT)" for me.
Component: Untriaged → JavaScript Engine
OS: Windows 8 → All
Product: Firefox → Core
Hardware: x86_64 → All
(new Date()).toLocaleString('en-US', { timeZoneName: 'long' }) returns "6/11/2014, 1:14:37 AM Eastern Daylight Time".

And actually this is correct:

> Actual results:
> 
> the GMT is listed as GMT-0500 (Eastern Standard Time)
> the GMT is listed as GMT-0400 (Eastern Daylight Time)

EST is -5, EDT is -4. That's my timezone in Toronto.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

4 years ago
When I send the date to the back end and when I log new Date() to the console in firebug this is what I get: 
Date {Wed Jun 11 2014 08:41:13 GMT-0400 (Eastern Standard Time)}.

In chrome and IE, when I log new Date(), I get this: 
Wed Jun 11 2014 09:12:23 GMT-0400 (Eastern Daylight Time)

I am using Firefox 29.0.1.
(Reporter)

Updated

4 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
What the built-in console of Firefox says? Any sample code?
Flags: needinfo?(zevvy2)
(Reporter)

Comment 5

4 years ago
Created attachment 8438499 [details]
console log for firebug
Flags: needinfo?(zevvy2)
(Reporter)

Comment 7

4 years ago
Created attachment 8438500 [details]
console log for chrome

Comment 8

3 years ago
This is Windows-specific.
Bug 879261, comment 1.
Bug 879261, comment 9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
OS: All → Windows
Resolution: --- → DUPLICATE
Duplicate of bug: 879261
You need to log in before you can comment on or make changes to this bug.