[FirefoxOS_v1.4][7715] the string "date" under the new contacts birthday item is untranslated in Bengali

RESOLVED DUPLICATE of bug 987966

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 987966
4 years ago
4 years ago

People

(Reporter: yaoyao.wu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
1 Suspect mozL10n.get ('date.placeholder') do a special treatment for a string with '.'
    confirm date-l10n-id  in contacts.en-US.properties exist: date.placeholder = Date, 
    track code with nightly :window.LazyL10n.get (function localized (_) {
    var textstr = _ ('date.placeholder');} textstr return value: ""
2 suspect sting ".placeholder" is specially  treatmented 
   in html: <input placeholder = "Street" data-field = "streetAddress" data-l10n-id = "streetAddress" name = "adr [# i #]   [streetAddress]" class = "textfield" type = "text "x-inputmode =" latin-prose "value =" # streetAddress # "id =" streetAddress_ # i # "> 
  In corresponding  properties file only exitst streetAddress.placeholder = Street, no "streetAddress" corresponding translation, but the correct corresponding character can switch between different languages.
(Reporter)

Comment 1

4 years ago
Hi,
Could you please help ask the module owner to pay attention to the problem?
Flags: needinfo?(tzhuang)
Flags: needinfo?(ehung)
Hi Yaoyao, 

I have two questions:
1. Do you mean bn-BD or bn-IN? I saw that 'date' or 'date.placeHolder' is translated in bn-IN but not in bn-BD
  https://hg.mozilla.org/gaia-l10n/bn-IN/file/0e85d8bbe0d2/apps/communications/contacts/contacts.properties
  https://hg.mozilla.org/gaia-l10n/bn-BD/file/3df6b50ccbe5/apps/communications/contacts/contacts.properties

2. Do you refer v1.4 or v1.3t branch? You type v1.4 on bug title but flag 1.3t? which is a bit of confusing

As for missing l10n strings, I think we should ask l10n team for help.
Flags: needinfo?(tzhuang) → needinfo?(l10n)

Updated

4 years ago
blocking-b2g: 1.3T? → 1.4?
(Reporter)

Comment 3

4 years ago
(In reply to Tzu-Lin Huang [:dwi2][:tzhuang] from comment #2)
> Hi Yaoyao, 
> 
> I have two questions:
> 1. Do you mean bn-BD or bn-IN? I saw that 'date' or 'date.placeHolder' is
> translated in bn-IN but not in bn-BD
>  
> https://hg.mozilla.org/gaia-l10n/bn-IN/file/0e85d8bbe0d2/apps/communications/
> contacts/contacts.properties
>  
> https://hg.mozilla.org/gaia-l10n/bn-BD/file/3df6b50ccbe5/apps/communications/
> contacts/contacts.properties
> 
> 2. Do you refer v1.4 or v1.3t branch? You type v1.4 on bug title but flag
> 1.3t? which is a bit of confusing
> 
> As for missing l10n strings, I think we should ask l10n team for help.


Hi Tzu-lin,
1 I mean bn-BD,  ‘date' or 'date.placeholder' is translated in file"gaia-l10n/bn-BD/apps/communications/contacts/contacts.properties"
date                      =তারিখ
date.placeholder          = তারিখ
2 sorry ,I refer v1.4 branch

and the corresponding html:
<span id="date-text_#i#" data-l10n-id="date.placeholder" class="datetime placeholder"> Date</span>
It's not an issue with this locale. Problem was fixed on master (2.0), but not on 1.4
Marking as duplicate of bug 987966.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(l10n)
Resolution: --- → DUPLICATE
Duplicate of bug: 987966

Updated

4 years ago
blocking-b2g: 1.4? → ---

Updated

4 years ago
Flags: needinfo?(ehung)
You need to log in before you can comment on or make changes to this bug.