[Loop] Keep Contacts Info updated

RESOLVED FIXED

Status

Firefox OS
Gaia::Loop
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: borjasalguero, Assigned: ferjm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

WIP
60 bytes, text/x-github-pull-request
jaoo
: review+
borjasalguero
: review+
borjasalguero
: feedback+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
We need to keep a cached version of the contacts we are using in our call log, but we need to update this info in our IndexedDB if any change happens in the Contact List.

As well we will create a ContactsHelper for retrieving the info of a contact given an ID, and other methods related.
(Reporter)

Updated

4 years ago
Depends on: 1023760
(Reporter)

Updated

4 years ago
Blocks: 1007937
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1035931
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
(Assignee)

Updated

4 years ago
Attachment #8455465 - Flags: review?(josea.olivera)
Attachment #8455465 - Flags: review?(borja.bugzilla)
Comment on attachment 8455465 [details] [review]
WIP

LGTM. r=me

I'm not very familiar with the call log/contact stuff. I would prefer Borja to take a look also before landing this.

Thanks Fernando!
Attachment #8455465 - Flags: review?(josea.olivera) → review+
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #3)
> Comment on attachment 8455465 [details] [review]
> WIP
> 
> LGTM. r=me
> 
> I'm not very familiar with the call log/contact stuff. I would prefer Borja
> to take a look also before landing this.

Oops, forgot to comment that do not forget to rebase this work as we already landed the bumping up version logic. Once you rebase, the version should be bumped up.
(Reporter)

Comment 5

4 years ago
Comment on attachment 8455465 [details] [review]
WIP

I think that there are some things to improve, so I've added some comments in Github. I'm keeping the r? flag in order to recheck this when ready. Thanks Fernando!
Attachment #8455465 - Flags: feedback+
(Assignee)

Updated

4 years ago
Attachment #8455465 - Flags: review?(borja.bugzilla)
(Assignee)

Updated

4 years ago
Attachment #8455465 - Flags: review?(borja.bugzilla)
(Reporter)

Comment 6

4 years ago
Comment on attachment 8455465 [details] [review]
WIP

This patch is working perfectly! R+!
Attachment #8455465 - Flags: review?(borja.bugzilla) → review+
(Assignee)

Comment 7

4 years ago
https://github.com/mozilla-b2g/firefoxos-loop-client/commit/07f04cacb73b5f5cd83e242780c895cd0f623f95
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1042601
You need to log in before you can comment on or make changes to this bug.