Closed Bug 1023818 Opened 6 years ago Closed 6 years ago

[User Story][Lockscreen] Taking action on lock screen notifications

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, firefox34 verified)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
Tracking Status
firefox34 --- verified

People

(Reporter: bhuang, Assigned: gweng)

References

Details

(Whiteboard: [2.1-feature-qa+])

User Story

As a user, I want to be able to directly action on the notifications on the lockscreen so I can quickly access the relevant apps after unlock.

Acceptance:
 - Use a gesture to access individual notifications
 - If the screen has a pin code lock then take the user to the unlock screen before entering the app

Attachments

(1 file)

As a user, I want to be able to directly action on the notifications on the lockscreen so I can quickly access the relevant apps after unlock.
The draft spec is now available for comment:

https://mozilla.box.com/s/gsklu2bl6ii98sbn8bsk

Future updates will be posted in the same folder.

Feel free to NI or email me with your questions.

Thanks!
Rob
Thanks Rob! Hi Greg, could you take a look to the spec see if we're good to implement it? Thanks!
Flags: needinfo?(gweng)
Okay, this seems not very difficult to implement it. I think the real challenge would be a reasonable code structure, which should be included in LockScreen as an app feature.
Flags: needinfo?(gweng)
feature-b2g: --- → 2.1
QA Whiteboard: [COM=SystemPlatform]
Blocks: 1043103
Hi Rob, I've made a concept proof version, and found there are some issues need UX' opinions:

1. Current LockScreen would clear the notifications while it unlocks. As an user, I found it's annoyed to trigger unlock, watch the window, and then lock it again to read more notifications but realized that all notifications got cleared. However, if we stop to clear the LockScreen notifications, while unlock, there is no 'clear all' button as the UtilityTray would put, so we don't know when we need to clear the notifications from LockScreen.

2. I don't see a flow for the phone with passcode. Should the actionable button be disabled, or to invoke the passcode, then wait user to unlock it with passcode and show the window?
Flags: needinfo?(rmacdonald)
I'd say this target milestone can be set as 2.1 s2. Hi Greg, feel free to change it, thanks!
Assignee: nobody → gweng
Target Milestone: --- → 2.1 S2 (15aug)
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #4)
> 1. Current LockScreen would clear the notifications while it unlocks. As an
> user, I found it's annoyed to trigger unlock, watch the window, and then
> lock it again to read more notifications but realized that all notifications
> got cleared. However, if we stop to clear the LockScreen notifications,
> while unlock, there is no 'clear all' button as the UtilityTray would put,
> so we don't know when we need to clear the notifications from LockScreen.

The notifications on the home screen only show what's new since you last used your phone as opposed to what's actually in your utility tray. So clearing the lock screen notifications upon unlock is the intended behaviour. This is the same reason we don't allow users to clear individual notifications on the lock screen. It's only meant to be a quick snapshot of what's new as opposed to the full list.

> 2. I don't see a flow for the phone with passcode. Should the actionable
> button be disabled, or to invoke the passcode, then wait user to unlock it
> with passcode and show the window?

Vivien had a patch whereby the passcode is displayed after the unlock. (Bruce is aware of this.) I'm not sure if it was included with the 2.0 release but it's definitely something we should include in 2.1. Following this logic, if the passcode is enabled, the user would hit the power button, see all their notifications, tap the open button and then enter their passcode. Only once the passcode is successfully entered will they go to the associated app. 

Hopefully this all makes sense, Greg, but NI me if you have more questions.
Flags: needinfo?(rmacdonald)
QA Whiteboard: [COM=SystemPlatform] → [COM=SystemPlatform][2.1-feature-qa+]
Hi, 

Attached is the VsD spec for actionable lockscreen. Let me know if you have any questions.

Thanks
Hi, I wonder how "Medium" the font-weight is (ex: 400?), for the actionable button. I now set it as "normal" (400) as "Medium". Thanks.
Flags: needinfo?(amlee)
And the bottom border of original notification, whether we should keep it or not, when the notification is highlighted?
From the spec I see no border under the highlighted notification, but I'm not sure.
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #8)
> Hi, I wonder how "Medium" the font-weight is (ex: 400?), for the actionable
> button. I now set it as "normal" (400) as "Medium". Thanks.

Hi Greg, 

The font looks good to me. Also the borders should be removed when the notification is highlighted. Thanks!
Flags: needinfo?(amlee)
Flags: in-moztrap?(gchang)
QA Contact: gchang
QA Whiteboard: [COM=SystemPlatform][2.1-feature-qa+] → [COM=SystemPlatform]
Whiteboard: [2.1-feature-qa+]
No longer blocks: 1043103
Depends on: 1043103
Add the test cases.
https://moztrap.mozilla.org/manage/cases/?filter-suite=742
Flags: in-moztrap?(gchang) → in-moztrap+
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
resolved fixed as dependent feature bug is done.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=SystemPlatform] → [COM=SystemPlatform][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=SystemPlatform][QAnalyst-Triage?] → [COM=SystemPlatform][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue is verified fixed on Flame 2.1(319mb) 

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

STR: 
1: Lock screen
2. Receive a text message
3. Tap on power button
4. Tap on text message
5. Tap on "Open"

Actual Result: Action on lock screen notifications is working as expected
QA Whiteboard: [COM=SystemPlatform][QAnalyst-Triage+] → [COM=SystemPlatform][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Please ignore comment 14. This issue cannot be closed verified fixed because of bug 1064630

The user is left in an unrecoverable state if they lock their device right after they enter a passcode while in the settings app.
QA Whiteboard: [COM=SystemPlatform][QAnalyst-Triage?] → [COM=SystemPlatform][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.