Closed Bug 1023888 Opened 7 years ago Closed 7 years ago

When exporting contacts via bluetooth and cancelling, an error screen appears

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected)

RESOLVED FIXED
tracking-b2g backlog
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected

People

(Reporter: sergi, Assigned: sergi, NeedInfo)

Details

Attachments

(4 files)

Attached image 2014-06-10-13-59-00.png
1. Contacts -> Export contacts
2. Select Bluetooth
3. Select a contact(s), tap 'Export'
4. Tap the close button (the 'X')

Expected:
The whole operation is cancelled and we're back to the main contacts list.

Actual:
Alert screen with 'Export error' message
Assignee: nobody → sergi.mansilla
blocking-b2g: --- → 2.0?
When this bug reproduces, what happens if you:

1. Select cancel on the export error screen? - Does this cancel the export operation?
2. Select retry? - Does this allow you to still export contacts?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> When this bug reproduces, what happens if you:
> 
> 1. Select cancel on the export error screen? - Does this cancel the export
> operation?
> 2. Select retry? - Does this allow you to still export contacts?


When the user sees the Export Error screen:
1. Selecting Cancel will successfully cancel the export of the contact via bluetooth.
2. Selecting Retry will successfully retry the export and the the user can continue and complete the export with no issue.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Prior test was completed on 1.4 Flame -  adding QA Wanted to check repro on 1.3 Flame
Flags: needinfo?(jmitchell)
Keywords: qawanted
This bug DOES repro on Flame 1.3. Export Error screen is seen.

Environmental Variables:
Device: Flame 1.3
Build ID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v10G-2

This bug DOES repro on Buri 2.0. Export Error screen is seen.

Environmental Variables:
Device: Buri Master
Build ID: 20140611124707
Gaia: 593b6b1765c76017fa575066f1139e5332595804
Gecko: 38fab6f7db66
Version: 32.0a2 (Master) 
Firmware Version: v1.2device.cfg

This bug DOES repro on Buri 1.4. Export Error screen is seen.

Environmental Variables:
Device: Buri 1.4
Build ID: 20140610034016
Gaia: c39db439202b29897bee9896bc789e6782809f3a
Gecko: edd648be2b07
Version: 30.0 (1.4) 
Firmware Version: v1.2device.cfg

This bug DOES repro on Buri v1.3. Export Error screen is seen.

Environmental Variables:
Device: Buri 1.3
Build ID: 20140611130105
Gaia: 7a69ecba7119b7f45fd91f291c1c996326f35978
Gecko: 96725a61c4fb
Version: 28.0 (1.3) 
Firmware Version: v1.2device.cfg
Flags: needinfo?(jmitchell)
The flags here is incorrect - this isn't a regression.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Long standing bug, so this isn't a blocker.
blocking-b2g: 2.0? → backlog
Attached file Github PR
Attachment #8440862 - Flags: review?(francisco)
Comment on attachment 8440862 [details] [review]
Github PR

Hi Jose,

can you take a look to this PR by Sergi?
Attachment #8440862 - Flags: review?(francisco) → review?(jmcf)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Comment on attachment 8440862 [details] [review]
Github PR

I've tested on the phone and worked ok. Please remove the '?' comments on the code and land once Travis is green

best
Attachment #8440862 - Flags: review?(jmcf) → review+
MErged at ef3e84e24961ac7f55b064371fc5a4db3d18ef48
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Keywords: verifyme
Hi William,

    Could you help with this bug? Because this bug has been failed verified on latest Flame v2.0.

Thank you very much.
  
See attachments: verify_v2.0.MP4 and logcat_0518.txt.
Reproduce rate: 5/5

Repro STR:
1. Go to "Export contacts" in Contacts app.
2. Select "Bluetooth".
3. Select some contacts, tap "Export".
**"Export error" prompt message will pop up after tapping Cancel button.  --KO
4. Turn on Bluetooth and then tap "X" icon.
**"Export error" prompt message will pop up after tapping "X" icon.  --KO

Flame 2.0 build:
Gaia-Rev        2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b961877cacba
Build-ID        20150202000205
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.034955
FW-Date         Mon Feb  2 03:50:05 EST 2015
Bootloader      L1TC000118D0
--------------------------------------------
Note: I can't repro this bug on Flame 2.1 and Flame 2.2.
Flags: needinfo?(whsu)
Keywords: verifyme
Hi, (In reply to Shally from comment #11)
> Hi William,
> 
>     Could you help with this bug? Because this bug has been failed verified
> on latest Flame v2.0.
> 
> Thank you very much.
>   

No problem. Thanks for your help! :)
Flags: needinfo?(whsu)
Hi, Jose,

Sorry to you.
May I have your help?
Could you please create v2.0&v2.0m PR?

v2.0&v2.0m need this patch because v2.0&v2.0m still can reproduce this bug.

* v2.0 branch
https://github.com/mozilla-b2g/gaia/blob/v2.0/apps/communications/contacts/js/export/bt.js#L129-L139
      finishCallback({
        'reason': reason
      }, 0, error.message);
      return true;
    };

    ContactToVcardBlob(contacts, function onContacts(blob) {
      if (cancelled) {
        finishCallback(null, 0);
        return;
      }

If you are not the right person, please let me know.
Many thanks.
Flags: needinfo?(jmcf)
(In reply to William Hsu [:whsu] from comment #15)
> Hi, Jose,
> 
> Sorry to you.
> May I have your help?
> Could you please create v2.0&v2.0m PR?
> 
> v2.0&v2.0m need this patch because v2.0&v2.0m still can reproduce this bug.
> 
> * v2.0 branch
> https://github.com/mozilla-b2g/gaia/blob/v2.0/apps/communications/contacts/
> js/export/bt.js#L129-L139
>       finishCallback({
>         'reason': reason
>       }, 0, error.message);
>       return true;
>     };
> 
>     ContactToVcardBlob(contacts, function onContacts(blob) {
>       if (cancelled) {
>         finishCallback(null, 0);
>         return;
>       }
> 
> If you are not the right person, please let me know.
> Many thanks.

Hi William,

Sergi is the author of the patch, so it makes sense that he provides the uplifted patch. I'm going to ni him. If he cannot respond and you are in a hurry I can try to do it myself. 

thanks!
Flags: needinfo?(jmcf) → needinfo?(sergi.mansilla)
(In reply to Jose Manuel Cantera from comment #16)
> (In reply to William Hsu [:whsu] from comment #15)

> Hi William,
> 
> Sergi is the author of the patch, so it makes sense that he provides the
> uplifted patch. I'm going to ni him. If he cannot respond and you are in a
> hurry I can try to do it myself. 
> 
> thanks!

Thanks Jose.
Have a nice day! :)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+][MGSEI-Triage+]
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.