DOM Inspector complains it cannot get Cc["@mozilla.org/inspector/flasher;1"] inIFlasher, rendering it non-functional.

RESOLVED DUPLICATE of bug 368608

Status

Other Applications
DOM Inspector
RESOLVED DUPLICATE of bug 368608
3 years ago
3 years ago

People

(Reporter: mconley, Unassigned)

Tracking

({addon-compat})

Firefox Tracking Flags

(Not tracked)

Details

STR:

1) Grab June 10th, 2014 Nightly, and install DOM Inspector 2.0.14, restart browser.
2) Open DOM Inspector

AR:

The DOMi window opens, but doesn't respond to use input.

ER:

A working DOMi.



This is in my terminal when I open a DOMi window:

Error getting service: @mozilla.org/inspector/flasher;1, inIFlasher
TypeError: Components.classes[aURL] is undefinedJavaScript error: chrome://inspector/content/Flasher.js, line 26: this.mShell is null
JavaScript error: chrome://inspector/content/inspector.xml, line 287: this.mTransactionManager is null

So I'm just assuming this first error about the flasher service is the start of the problem.
Tentatively marking blocking bug 1018324, since that removed inIFlasher.
Blocks: 1018324
For those following along at home, you can get back into a working state by backing out the following revisions locally, in this order:

http://hg.mozilla.org/mozilla-central/rev/4140ef233349
http://hg.mozilla.org/mozilla-central/rev/a4859b482f44
http://hg.mozilla.org/mozilla-central/rev/2e1413c075c0

Comment 3

3 years ago
Regression Range...

Good: https://hg.mozilla.org/integration/mozilla-inbound/rev/100a14518e5b

Bad : https://hg.mozilla.org/integration/mozilla-inbound/rev/066ed94a5868

Appears to be patch Bug 1022930


Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Comment hidden (typo)
Gary, the bug you mentioned is this bug. Can you mark that other bug as a duplicate of this one?

Comment 6

3 years ago
Bug 368608 seems fix this problem
Depends on: 368608

Comment 7

3 years ago
Not blocking since we have a fix in hand.
No longer blocks: 1018324
Keywords: addon-compat

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 368608
Resolution: --- → DUPLICATE
Duplicate of bug: 368608
You need to log in before you can comment on or make changes to this bug.