Closed Bug 1023945 Opened 6 years ago Closed 6 years ago

Ctrl+Spacebar "Open Context Menu" Keyboard Shortcut Doesn't Respond

Categories

(Firefox :: Untriaged, defect)

30 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: mikewabst, Unassigned)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

Hold down Ctrl+Spacebar to summon the context menu


Actual results:

Nothing happened, the context menu did not show.


Expected results:

Open up the context menu
Keywords: access, regression
Comment on attachment 8438501 [details]
Screenshot 2014-06-11 10.00.52.png

Example of the context menu summoned by Ctrl+Spacebar in previous version Firefox 29
Checked the Shift+F10 to check this context menu on Windows version, that works fine on FF29 and FF30 Win7
OS: Windows 7 → Mac OS X
This Firefox-specific feature has been removed. See Bug 435164 for the standard keyboard shortcut on OS X.
Blocks: 435164
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Is there any way to re-enable this shortcut? The built-in mechanism in Mac OS X doesn't work exactly the same. Here's one of my workflows that won't work anymore in Firefox 30.

1. hit F6 to focus current tab
2. ctrl+space to bring up the context menu for the tab
3. start typing "pin tab"
4. hit enter when the "pin tab" menu item is focused

The reason it's not working the same is that the OS assumes you want a context menu where the mouse pointer is (usually in the view port area of a web page), whereas CTRL+SPACE worked with the currently focused UI element.
You need to log in before you can comment on or make changes to this bug.