Shutdown regression Firefox 30 (Firefox is already running, but is not responding)

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: soeren.hentzschel, Unassigned)

Tracking

30 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
It looks like there is a serious shutdown regression in Firefox 30. Firefox 30 is only one day old and we already have ~ 10 (!) users in the German Firefox forum (camp-firefox.de) complaining that the computer has to be restarted or the Firefox process to be killed to get Firefox running ("Firefox is already running but not responding"). There are similar reports on my personal blog and in other forums. That's an unusal high number of reports for one single issue, so there seems a lot of users to be affected.

It's definitively not the same as bug 1005487 because Firefox 29 works for these users, it's a new issue since Firefox 30.
Here is a link to the *German* thread referenced in comment #0:

http://www.camp-firefox.de/forum/viewtopic.php?f=1&t=108806

Lots of people using G Data Antivirus but I can't reproduce that in my VM so far.
Component: Startup and Profile System → General
Product: Toolkit → Firefox

Comment 2

4 years ago
Please have people who are experiencing this issue follow the instructions at https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox to get crash reports/stacktraces.
Multiple people report that closing Firefox works fine when run as Admin. Hangs on shutdown when run as a normal user.
Thanks to Sören for guiding the discussion and giving people instructions on how to help us here!
(Reporter)

Comment 8

4 years ago
Running Firefox as administrator is one possible "solution", there seems to be another one: disabling the G-Data Exploit Protection.

Comment 9

4 years ago
Confirmed. The same here. I was one of the first who encountered this issue and filed a bug report (bug) as well as starting Mozilla Support discussion here: https://support.mozilla.org/ru/questions/997918

Comment 10

4 years ago
By the way, using Firefox 30 as a normal user but under Debian Linux.

Comment 11

4 years ago
And it has nothing to do with antivirus software as you may guess.

Comment 12

4 years ago
I've disabled the Exploit Prot. by G-DATA Internet Security 2015 and now it works for me.. but that can not be the right way to do this..
(Reporter)

Comment 13

4 years ago
G-Data solved the problem with a signature update for the security suite, a few users in our forum already confirmed that Firefox works by now.
So does anybody understand what in G-Data caused the issue that affected G-Data users?

Also, Alex, can you provide us with a stack, as detailed in comment 2?

Comment 15

4 years ago
Strange, but I cannot reproduce this isssue anymore. Maybe there was something wrong with my profile when I accidentally reproduced it under Firefox 30. I dunno. Really strange.

Well, if it doesn't affect anybody else I think it's time to close this bug.
Agreed, let's close this bug until someone reopens it. Would be great to figure out the actual cause but I unfortunately doubt that we'll get there.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Hardware: x86 → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.