Status

()

Core
JavaScript Engine
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jandem, Assigned: bhackett)

Tracking

unspecified
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
32 moved to Aurora a few days ago, it seems like we can remove YARR now. I'm not aware of any (critical) issues/regressions with irregexp.

This would help the Latin1 string work (bug 998392), as it means I don't have to worry about keeping the dead YARR code working while refactoring regex code.

Updated

3 years ago
Depends on: 1024132
(Reporter)

Updated

3 years ago
Flags: needinfo?(bhackett1024)
(Assignee)

Comment 1

3 years ago
Per IRC discussion I'd like to wait until the remaining irregexp crashes get sorted out (bug 1013586 and bug 1013589) before removing yarr entirely.
Depends on: 1013586, 1013589
Flags: needinfo?(bhackett1024)
(Assignee)

Comment 2

3 years ago
Created attachment 8440459 [details] [diff] [review]
patch

It looks like the irregexp crash bugs have been sorted out.
Assignee: nobody → bhackett1024
Attachment #8440459 - Flags: review?(jdemooij)
(Reporter)

Comment 3

3 years ago
Comment on attachment 8440459 [details] [diff] [review]
patch

Review of attachment 8440459 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!

I have some regex patches that will be a lot nicer now; will rebase them on top of this.
Attachment #8440459 - Flags: review?(jdemooij) → review+
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ca3c665be1b
https://hg.mozilla.org/mozilla-central/rev/5ca3c665be1b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
(Reporter)

Updated

3 years ago
Blocks: 1028064
No longer depends on: 1024132
You need to log in before you can comment on or make changes to this bug.