Closed Bug 1024123 Opened 6 years ago Closed 6 years ago

<input type="number"> spinners don't grow (in height) when the control grows

Categories

(Core :: Layout: Form Controls, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 947365

People

(Reporter: dholbert, Unassigned)

Details

STR:
 1. Load:

data:text/html,<input type="number" style="height:100px;font:80px serif" value="0">

 2. Try to use the spinner buttons to adjust the value

ACTUAL RESULTS: The spinners (and their click-region) are teeny-tiny compared to the size of the <input>.

EXPECTED RESULTS: Intuitively, I expect the buttons (or at least their vertical click target region) to grow with the control.

Note that at the default height, the full vertical strip that the spinners occupy seems to be clickable & will adjusts the number value. It seems odd that this is no longer the case at larger control sizes.


For comparison, Chrome (Version 37.0.2041.4 dev) has the spinners occupy the full vertical height of the number-control, in my data URI testcase, though they only show up on hover.
Oh, I think this is a duplicate of bug 947365. Sorry for any bugspam caused.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947365
You need to log in before you can comment on or make changes to this bug.