Closed Bug 1024406 Opened 5 years ago Closed 5 years ago

Displaying only file names is confusing

Categories

(DevTools :: Netmonitor, defect)

32 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 903465

People

(Reporter: kiril, Unassigned)

Details

Attachments

(1 file)

Attached image ff_network_paths.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140611004004

Steps to reproduce:

1. Open the developer tools
2. Go to Network panel
3. Refresh the page
4. Try to guess the actual path of files like `/`, `/?page=...`, `/?limit=...`


Actual results:

I've tried it with a one-page-app site. The website is fetching asynchronously a lot of resources and all I see in the network panels are several files named `/?limit=0&offset=0`. In order to find a concrete request (e.g. `/api/2.0/drives/?limit=0&offset=0`) I have to click on each of the requests, view the details for it and go to the next one if I'm not lucky.

Screenshot attached.


Expected results:

I expect to see the full path of each resource there.
Component: Untriaged → Developer Tools: Netmonitor
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903465
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.