Right inner shadow displayed in the absence of overflowing tab bar

VERIFIED FIXED in mozilla33

Status

()

Toolkit
XUL Widgets
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: adalucinet, Assigned: dao)

Tracking

33 Branch
mozilla33
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 s=33.1 [qa!])

Attachments

(1 attachment)

759 bytes, patch
Neil Deakin (not available until Aug 9)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

3 years ago
Reproducible on the latest Nightly (BuildID: 20140612030349): 
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:33.0) Gecko/20100101 Firefox/33.0

STR:
1. Launch Nightly.
2. Open at least 18 tabs.
3. Close the first 2 tabs from the left side.

Expected results: The right inner shadow is not displayed.

Actual results: The right inner shadow is displayed after the Open a New tab (+) button.

Notes:
1. Reproducible on Mac OS X 10.9.2 [1] and Ubuntu 14.04 x32 [2]. On Mac OS X, a vertical line is displayed on some of the tabs at mouse over: http://goo.gl/RldwSN, after performing the above steps.
2. Screencast: http://goo.gl/r1fzKO 
3. Same actual result if I drag the first two tabs in a New Window.
4. The shadow disappears when I open a New Tab.
5. Not reproducible with builds before bug 878020.

[1] Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
[2] Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1024497
(Assignee)

Updated

3 years ago
Component: Theme → XUL Widgets
Product: Firefox → Toolkit
(Assignee)

Comment 2

3 years ago
Created attachment 8439269 [details] [diff] [review]
patch

The scrolledtoend attribute was left behind. We need to call _updateScrollButtonsDisabledState after changing the notoverflowing attribute.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8439269 - Flags: review?(enndeakin)
(Assignee)

Comment 3

3 years ago
Marco, please add this to the current iteration.
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Whiteboard: p=1 [qa+]
Attachment #8439269 - Flags: review?(enndeakin) → review+
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: p=1 [qa+] → p=1 s=33.1 [qa+]
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/626291e664ab
https://hg.mozilla.org/mozilla-central/rev/626291e664ab
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
QA Contact: alexandra.lucinet
(Reporter)

Comment 7

3 years ago
Verified as fixed with latest Nightly 33.0a1 (Build ID: 20140613030203) on Windows 7 x64 [1], Ubuntu 14.04 x32 [2] and Mac OS X 10.9.2 [3].

[1] Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:33.0) Gecko/20100101 Firefox/33.0
[2] Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0
[3] Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Status: RESOLVED → VERIFIED
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa!]
You need to log in before you can comment on or make changes to this bug.