Closed Bug 1024517 Opened 5 years ago Closed 5 years ago

[Flame] Video app sometimes fails to index videos.

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1050667

People

(Reporter: RobertC, Unassigned)

References

Details

Attachments

(6 files, 3 obsolete files)

Video app tests are failing because tapping on the thumbnail does not work.
http://selenium.qa.mtv2.mozilla.com:8080/view/B2G/job/b2g.flame.mozilla-central.ui.non-smoketest/65/HTML_Report/

This issue cannot be reproduced manually. I ran the tests locally and they failed consistently.

Build info (flame):
Gaia      41db6954a67efc55016744bc8f6591ae9e07a285
Gecko     https://hg.mozilla.org/mozilla-central/rev/9e8e3e903484
BuildID   20140612040203
Version   33.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014


Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette_test.py", line 170, in run
testMethod()
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/videoplayer/test_play_webm_video.py", line 31, in test_play_webm_video
fullscreen_video = video_player.tap_first_video_item()
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/videoplayer/app.py", line 43, in tap_first_video_item
fullscreen.wait_for_player_frame_displayed()
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/videoplayer/regions/fullscreen_video.py", line 19, in wait_for_player_frame_displayed
self.wait_for_element_displayed(*self._video_player_frame_locator)
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 42, in wait_for_element_displayed
lambda m: m.find_element(by, locator).is_displayed())
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.0 seconds


NOTE: While the test ran I tried tapping on the video and it still would not load.
This seems to be a bug in the tests.
I can see it constantly scanning for files
The test_play_webm_video failed in the latest v1.4 build too, for the same reason. 
I was able to reproduce the failure locally, by running the automated test, intermittently (rarely). 
I was not able to reproduce it manually. 

#Env:
Gaia      7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/bcd308fbbf38
BuildID   20140612000202
Version   30.0
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

Jenkins report: http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-b2g30_v1_4.ui.non-smoketest/19/HTML_Report/
I attached a logcat of the issue.
Attached file logcat (obsolete) —
might be the dup of bug 1024324
Priority: -- → P1
Assignee: nobody → andrei.hutusoru
Attached file Full Logcat when the test failed (obsolete) —
Attached file test_video_3gp.log
The last one included results from several tests.
Here is a better logcat.

Notable events:
Line 1580:  Video app is launched

Line 1711: Javascript Warning 
E/GeckoConsole( 7646): [JavaScript Warning: "Media resource blob:9a47ad0a-b3e3-406e-a2e3-1b7db7c3ed16 could not be decoded." {file: "app://video.gaiamobile.org/index.html" line: 0}]

Line 1774: JS Error
E/GeckoConsole( 7646): Content JS ERROR at app://video.gaiamobile.org/gaia_build_defer_index.js:483 in getMetadata/offscreenVideo.onerror: Can't play video /sdcard/tests/VID_0001.3gp [object XrayWrapper [object Event]]

Jsmith, can you advise, do you know who to direct this logcat to?
Attachment #8439235 - Attachment is obsolete: true
Attachment #8446482 - Attachment is obsolete: true
Flags: needinfo?(jsmith)
Duplicate of this bug: 1020298
Hema - Can someone from your team take a look at the logcat provided & provide feedback on the problem here?
Flags: needinfo?(jsmith) → needinfo?(hkoka)
Russ can you help here?
Flags: needinfo?(hkoka) → needinfo?(rnicoletti)
The error

"E/GeckoConsole( 7646): Content JS ERROR at app://video.gaiamobile.org/gaia_build_defer_index.js:483 in getMetadata/offscreenVideo.onerror: Can't play video /sdcard/tests/VID_0001.3gp [object XrayWrapper [object Event]]"

indicates the video metadata could not be read. This happens when the video is being loaded into an 'offscreen' video element for the purposes of getting the metadata. In this case, the cause of the error is that the video could not be decoded. 

It does seem like the problem of the video app not being able to load the video is due to bug 1024324 because I flashed the latest master build on my flame and the video loads successfully.
Flags: needinfo?(rnicoletti)
We should check if this reproduces post landing of bug 1024405, as I think that might be the root cause of the problem here.
(In reply to Jason Smith [:jsmith] from comment #12)
> We should check if this reproduces post landing of bug 1024405, as I think
> that might be the root cause of the problem here.

Clarified offline, but still reproduces post landing of that patch.
Do you have a logcat for the latest failure? Are you still seeing the JS error from comment #6?
Flags: needinfo?(jsmith)
(In reply to Russ Nicoletti [:russn] from comment #14)
> Do you have a logcat for the latest failure? Are you still seeing the JS
> error from comment #6?

Zac could probably help answer this.
Flags: needinfo?(jsmith) → needinfo?(zcampbell)
Attached file vid_fail_2.log
I can still replicate this, around 2 in 20.

I've attached a new logcat, although the error message looks the same.

Device: Flame
Gaia      1412afd61342da6a0517c7bd2e5e22ef57715517
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/5aca12a38f2c
BuildID   20140702012902
Version   33.0a1
ro.build.version.incremental=eng.cltbld.20140624.101744
ro.build.date=Tue Jun 24 10:17:54 EDT 2014
Flags: needinfo?(zcampbell)
It's odd that the error would be intermittent. Anyway, I'm trying to recreate on my box but I'm not able to run gaiatest/apps/videoplayer/regions/fullscreen_video.py. I can run other ui tests but when I run that one in particular it doesn't execute. Input and output below:

russ@russ:~/sandbox/mozilla/gaia/tests/python/gaia-ui-tests$ gaiatest --address=localhost:2828 --testvars=gaiatest/testvars_template.json --restart ./gaiatest/apps/videoplayer/regions/fullscreen_video.py 
starting httpd
running webserver on http://192.168.1.221:38881/ serving content from /usr/local/lib/python2.7/dist-packages/marionette_client-0.7.10-py2.7.egg/marionette/www
TEST-START fullscreen_video.py

SUMMARY
-------
passed: 0
failed: 0
todo: 0

Any suggestions?
Flags: needinfo?(zcampbell)
Yes that's not a test file, it's a class. The test file is:

gaiatest/tests/functional/videoplayer/test_play_3gp_video.py

you can also add --repeat 10
Flags: needinfo?(zcampbell)
I'm able to reproduce now. However, I'm not able to see additional logging that I've added in my logcat output so I'm not able to narrow down when in the process this is happening. In any event, the intermittent error decoding the video would appear to be a gecko issue. 

Jason, can you ni a gecko dev to have them look into this intermittent decoding error? Thanks.
Flags: needinfo?(jsmith)
I know Chris landed bug 979104, which could be related to this.

Chris - Any thoughts on the root cause here? Could it be caused by bug 979104?
Flags: needinfo?(jsmith) → needinfo?(cpearce)
Yes, this could be caused by bug 979104. Please ensure that the build your testing includes the fix from bug 1024405:

https://hg.mozilla.org/mozilla-central/rev/b30fb4ddf36d
Flags: needinfo?(cpearce)
Can you retest this tomorrow?
Blocks: 979104
Flags: needinfo?(robert.chira)
Assignee: andrei.hutusoru → nobody
Ran the test locally and it reproduced 20% of the time

Build info v2.1 flame:
Gaia      b597b86274ab109d7ef530bc0c4b6adccddae4e4
Gecko     https://hg.mozilla.org/mozilla-central/rev/e8df6826a571
BuildID   20140704040205
Version   33.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

This is also reproduced on v2.0:
Gaia      8193ad514e27440154684f112a5796e65f13fd93
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/552da2802e91
BuildID   20140704000201
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
Flags: needinfo?(robert.chira)
Summary: [Flame][v2.1] Investigate Video app test failures → [Flame] Investigate Video app test failures
add better error messages on video tests
Attachment #8460902 - Flags: review?(zcampbell)
Attachment #8460902 - Flags: review?(viorela.ioia)
Comment on attachment 8460902 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22074

r+
Attachment #8460902 - Flags: review?(viorela.ioia) → review+
Merged in: https://github.com/mozilla-b2g/gaia/commit/28cace960088ae624227f05f7fe60408d742211f.
The bug still opened as the issue is not fixed.
Uplift to 2.0
Attachment #8460902 - Attachment is obsolete: true
Attachment #8460902 - Flags: review?(zcampbell)
Attachment #8461560 - Flags: review?(viorela.ioia)
Attachment #8461560 - Flags: review?(andrei.hutusoru)
Comment on attachment 8461560 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22119

Merged on v2.0:
https://github.com/mozilla-b2g/gaia/commit/68226b3fd4eba752307daa5e917238bde253f5ab
Attachment #8461560 - Flags: review?(viorela.ioia)
Attachment #8461560 - Flags: review?(andrei.hutusoru)
Attachment #8461560 - Flags: review+
Attached image No videos found
From the latest reports we see a intermittent fail with the video app not being able to find the video files from the device.

See:
http://jenkins1.qa.scl3.mozilla.com/job/flame.b2g-inbound.ui.functional.smoke/331/HTML_Report/


Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.7.11-py2.7.egg/marionette/marionette_test.py", line 170, in run
testMethod()
File "/var/jenkins/2/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/videoplayer/test_play_3gp_video.py", line 23, in test_play_3gp_video
video_player.wait_for_thumbnails_to_load(1, 'Video files found on device: %s' %self.data_layer.video_files)
File "/var/jenkins/2/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/videoplayer/app.py", line 28, in wait_for_thumbnails_to_load
timeout=timeout, message=message)
File "/var/jenkins/2/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 54, in wait_for_condition
Wait(self.marionette, timeout).until(method, message=message)
File "/var/jenkins/2/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.7.11-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 35.1 seconds with message: Video files found on device: [u'/sdcard/tests/VID_0001.3gp']
Flags: needinfo?(zcampbell)
Flags: needinfo?(jsmith)
Does this issue reproduce manually?
Flags: needinfo?(jsmith)
Bebe, can you capture a logcat? Does it have the same error message as described in comment #6 and #11?

It sounds suspiciously like the same problem.
Flags: needinfo?(zcampbell)
Flags: needinfo?(florin.strugariu)
Attached file logcat of the issue
I could not reproduce this fail on the today's build
BuildID   20140729160207

But this doesn’t mean that the issue is not reproducible any more

But looking in jenkins this is the same fail as you mentioned.

The logcat is from build:
http://jenkins1.qa.scl3.mozilla.com/job/flame.mozilla-central.ui.functional.non-smoke/37


 Showing version details
 application_buildid: 20140728160201
 application_changeset: 75fe3b8f592c
 application_display_name: B2G
 application_name: B2G
 application_repository: https://hg.mozilla.org/mozilla-central
 application_version: 34.0a1
 build_changeset: 3aa6abd313f965a84aa86c6b213dc154e4875139
 device_firmware_date: 1406125546
 device_firmware_version_incremental: eng.cltbld.20140723.102536
 device_firmware_version_release: 4.3
 device_id: flame
 gaia_changeset: fadfafa17f5175203b8b9457bfb95e5816f54f58
 gaia_date: 1406567470
 gecko_changeset: 5c20e8c063aa7bbb2f9f12353a67ba6c595d248a
 platform_buildid: 20140728160201
 platform_changeset: 75fe3b8f592c
 platform_repository: https://hg.mozilla.org/mozilla-central
Flags: needinfo?(florin.strugariu)
I was able to reproduce this issue with automation on v2.0 today.

From the logcat I can see:

E/GeckoConsole( 1428): Content JS WARN at app://system.gaiamobile.org/js/app_window_manager.js:102 in awm_display: the app has been displayed.
E/GeckoConsole( 1428): [JavaScript Error: "TypeError: element is null" {file: "app://system.gaiamobile.org/js/task_manager.js" line: 416}]


Build ID:
Device firmware (date) 	31 Aug 2014 13:31:23
Device firmware (incremental) 	eng.cltbld.20140831.163113
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	05 Sep 2014 12:26:56
Gaia revision 	f02a8e4ef0fa
Gecko build 	20140908000202
Gecko revision 	8e46e547f4ad
Gecko version 	32.0



This test is failing on and off for some time now. I can't generate a proper regression range using our Jenkins logs.

Reproduction rate:
3/5 running:

https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/videoplayer/test_play_3gp_video.py


Manual STR:

1. Add file to sdcard:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/resources/VID_0001.3gp
2. Insert SDcard to phone
3. Start the phone and open video app

Actual:
3. The video app can't find any videos
Can someone else confirm the reproduction rate above manually?
Keywords: qawanted
Duplicate of this bug: 1054494
I don't think the error in comment #34 is the correct one.

I can replicate this intermittently by running the test locally.

In that scenario I get this error message:

E/GeckoConsole(12491): Content JS ERROR at app://video.gaiamobile.org/gaia_build_defer_index.js:528 in getMetadata/offscreenVideo.onerror: Can't play video /sdcard/tests/VID_0001.3gp [object Event]
Summary: [Flame] Investigate Video app test failures → [Flame] Video app sometimes fails to index videos.
DJF, based on the above error message on a device after pushing a file to it. It's an intermittent at about 1 in 10.

Can I expand that error message somehow (e.stack or e.message?) or enhance the debugging to find out why this failed?

We are pushing the file which is 132kb with adb so it really shouldn't be any problem here.
Flags: needinfo?(dflanagan)
(In reply to Zac C (:zac) from comment #38)
> DJF, based on the above error message on a device after pushing a file to
> it. It's an intermittent at about 1 in 10.
> 
> Can I expand that error message somehow (e.stack or e.message?) or enhance
> the debugging to find out why this failed?
> 
> We are pushing the file which is 132kb with adb so it really shouldn't be
> any problem here.

If you haven't already found it in the source code, the error is being printed at apps/video/js/metadata.js:184

Note that the variable e is an Event object, not an Error object, so it probably doesn't have a stack trace.  I'm not actually sure what it has. It looks like I was hoping it had a meaningful toString() method since I passed it directly to the console.error() function. You might just need to do a for/in loop over the object to see whether it has any useful properties.  I suspect you won't find much, however.

Does the bug go away if you use a .webm or other video format instead of .3gp? IIRC .3gp uses h.264. And if the decoder for that relies on any kind of hardware acceleration on the host machine, perhaps there is some kind of contention for that or other problem?  If you're not trying to test specifically for .3gp support here, perhaps you could just make the intermittent go away with a different format.
Flags: needinfo?(dflanagan)
Thanks djf, this bug is not specific to 3gp. We have seen it with other video formats in the past but at the moment I'm focusing on this one. The host is the Flame device so it should have the codec and it should run fine.

We don't see any similar issues for music or gallery apps which gives me some trust in the framework that we're using to push and pull files to the device.

(It may also be related to bug https://bugzilla.mozilla.org/show_bug.cgi?id=1065989)

I'll have to come back to this on Monday, or if you're interested in running the tests yourself the instructions are in comment #4 of bug 1065989.
djf, would you mind debugging this for us? I do think it's worthy of investigation by a Video app dev seeing as the issue is unique to Video app, I feel comfortable excluding the test framework from blame.
Flags: needinfo?(dflanagan)
I dumped videofile and the event:



09-15 15:32:05.100 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:184 in getMetadata/offscreenVideo.onerror: Can't play video /sdcard/tests/VID_0001.3gp [object Event]
09-15 15:32:05.100 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video name  -> /sdcard/tests/VID_0001.3gp
09-15 15:32:05.100 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video lastModifiedDate  -> Thu Mar 13 2014 11:42:14 GMT+0100 (UTC)
09-15 15:32:05.100 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video type  -> video/3gpp
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video size  -> 123243
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video slice  -> function slice() {
09-15 15:32:05.110 E/Video   ( 7230):     [native code]
09-15 15:32:05.110 E/Video   ( 7230): }
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video path  -> 
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:186 in getMetadata/offscreenVideo.onerror: video mozFullPath  -> 
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e isTrusted -> true
09-15 15:32:05.110 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e stopPropagation -> function stopPropagation() {
09-15 15:32:05.110 E/Video   ( 7230):     [native code]
09-15 15:32:05.110 E/Video   ( 7230): }
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e stopImmediatePropagation -> function stopImmediatePropagation() {
09-15 15:32:05.120 E/Video   ( 7230):     [native code]
09-15 15:32:05.120 E/Video   ( 7230): }
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e preventDefault -> function preventDefault() {
09-15 15:32:05.120 E/Video   ( 7230):     [native code]
09-15 15:32:05.120 E/Video   ( 7230): }
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e initEvent -> function initEvent() {
09-15 15:32:05.120 E/Video   ( 7230):     [native code]
09-15 15:32:05.120 E/Video   ( 7230): }
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e getPreventDefault -> function getPreventDefault() {
09-15 15:32:05.120 E/Video   ( 7230):     [native code]
09-15 15:32:05.120 E/Video   ( 7230): }
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e type -> error
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e target -> [object HTMLVideoElement]
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e currentTarget -> [object HTMLVideoElement]
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e eventPhase -> 2
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e bubbles -> false
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e cancelable -> false
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e defaultPrevented -> false
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e timeStamp -> 1410791525081773
09-15 15:32:05.120 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e originalTarget -> [object HTMLVideoElement]
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e explicitOriginalTarget -> [object HTMLVideoElement]
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e NONE -> 0
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e CAPTURING_PHASE -> 1
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e AT_TARGET -> 2
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e BUBBLING_PHASE -> 3
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e ALT_MASK -> 1
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e CONTROL_MASK -> 2
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e SHIFT_MASK -> 4
09-15 15:32:05.130 E/Video   ( 7230): Content JS ERROR at app://video.gaiamobile.org/js/metadata.js:189 in getMetadata/offscreenVideo.onerror: e META_MASK -> 8
Zac: The info in the comment above doesn't seem to tell me anything useful, except maybe the file size. Is that the correct file size? Also, you've said that it is not specific to .3gp. What I'm really wondering is whether it is specfic to video formats that need to use hardware for decoding. I think that an .ogv video would be pure software and that other formats probably use hardware (though I don't really know for sure.) So knowing whether this reproduces with .ogv would probably tell us a lot.

I don't think I can personally help debug this, because it does not look like a Gaia issue. It looks to me like something is going wrong in gecko or gonk. 

Aseking thought this might be a dupe of 1024324, and Sotaro worked on that bug, so maybe he will have some insight for this one...  

Sotaro: could you take a look at the logcat in https://bug1024517.bugzilla.mozilla.org/attachment.cgi?id=8464594 and see if it tells you anything about why the video is failing to load here? Note that this apparently only happens when the video app is being run by Marionette tests. In particular, I'm curious about these messages from the log:

  E WVMExtractor: Failed to open libwvm.so

  V IMediaResourceManagerDeathNotifier: getMediaResourceManagerService

  V GonkConsumerBase: abandon
Flags: needinfo?(zcampbell)
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(dflanagan)
Recently, Bug 1050667 is created. It seems similar bug. Comment 42 does not provide the information about the problem.
Flags: needinfo?(sotaro.ikeda.g)
Thanks Sotaro,

I tried our automated test with the Webm file attached to bug 1050667 and I replicated the bug immediately, although that was fortunate, it's still an intermittent issue.

I agree it's similar and I'm going to mark this as a duplicate of that one and observe the results after that patch has landed.

dfj, thanks for your help! I wish I'd had the time to push on this sooner, we might have found it before the partner did.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(zcampbell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1050667
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.