crash opening page in new tab

VERIFIED DUPLICATE of bug 101554

Status

--
critical
VERIFIED DUPLICATE of bug 101554
17 years ago
10 years ago

People

(Reporter: njriley, Assigned: hyatt)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)
BuildID:    2001092820

When I was opening a page in a new tab within the same window, Mozilla crashed.  It 
caused my system to completely lock up, to the point I had to hit the reset button 
(Mozilla shot up to 100% CPU and refused to be killed.)

Reproducible: Couldn't Reproduce
Steps to Reproduce:


Here's what I got from CrashReporter:

Date/Time:  2001-09-30 16:57:25 -0500
OS Version: 10.1 (Build 5G64)

Command:    Mozilla
PID:        414

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0:
 #0   0x02517f50 in nsXULWindow::GetPrimaryContentShell(nsIDocShellTreeItem **)
 #1   0x00000000 in 0x0
 #2   0x02512f3c in 
GetPrimaryContentShell__17nsChromeTreeOwnerFPP19nsIDocShellT
re
 #3   0x0311e93c in GlobalWindowImpl::GetContent(nsIDOMWindow **)
 #4   0x0058f754 in XPTC_InvokeByIndex
 #5   0x0058f648 in XPTC_InvokeByIndex
 #6   0x025c2c9c in 0x25c2c9c
 #7   0x025c8e64 in XPC_WN_GetterSetter(JSContext *, JSObject *, unsigned int, l
ong *, long *)
 #8   0x023f522c in js_Invoke
 #9   0x023f54c4 in js_InternalInvoke
 #10  0x02408ba4 in js_GetProperty
 #11  0x023fbf94 in 0x23fbf94
 #12  0x023f5284 in js_Invoke
 #13  0x023f54c4 in js_InternalInvoke
 #14  0x023fd878 in 0x23fd878
 #15  0x023f5284 in js_Invoke
 #16  0x025bc900 in 0x25bc900
 #17  0x025ba1a0 in 
CallMethod__14nsXPCWrappedJSFUsPC15nsXPTMethodInfoP17nsXPTCM
in
 #18  0x0058fbc8 in PrepareAndDispatch
 #19  0x00593b88 in nsProcessConstructor(nsISupports *, nsID const &, void **)
 #20  0x029a0a00 in 
HandleEventSubType__22nsEventListenerManagerFP16nsListenerSt
ru
 #21  0x029a1f78 in 0x29a1f78
 #22  0x02bca324 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #23  0x02bca224 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #24  0x02bca224 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #25  0x02bca224 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #26  0x02bca224 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #27  0x02bca224 in 
HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP1
1n
 #28  0x02bd16e8 in nsXULElement::HandleChromeEvent(nsIPresContext *, nsEvent *,
  **)
 #29  0x0311d834 in GlobalWindowImpl::HandleDOMEvent(nsIPresContext *, nsEvent 
*
,  *)
 #30  0x0292448c in 
HandleDOMEvent__10nsDocumentFP14nsIPresContextP7nsEventPP11n
sI
 #31  0x029b10fc in 
SendFocusBlur__19nsEventStateManagerFP14nsIPresContextP10nsI
Co
 #32  0x029aff50 in 0x29aff50
 #33  0x029aa458 in 0x29aa458
 #34  0x033d8db8 in 
HandleEventInternal__9PresShellFP7nsEventP7nsIViewUiP13nsEve
nt
 #35  0x033d8a24 in PresShell::HandleEvent(nsIView *, nsGUIEvent *, nsEventStatu
s *)
 #36  0x03613bb8 in nsView::HandleEvent(nsGUIEvent *, unsigned int, nsEventStatu
s *, int, int &)
 #37  0x03613b28 in nsView::HandleEvent(nsGUIEvent *, unsigned int, nsEventStatu
s *, int, int &)
 #38  0x03613b28 in nsView::HandleEvent(nsGUIEvent *, unsigned int, nsEventStatu
s *, int, int &)
 #39  0x03624b5c in 0x3624b5c
 #40  0x03612fb0 in HandleEve
 #41  0x02819c28 in nsWindow::DispatchEvent(nsGUIEvent *, nsEventStatus &)
 #42  0x02819cfc in nsWindow::DispatchWindowEvent(nsGUIEvent &)
 #43  0x02819e40 in nsWindow::DispatchMouseEvent(nsMouseEvent &)
 #44  0x0282994c in nsMacEventHandler::HandleMouseDownEvent(EventRecord &)
 #45  0x02828164 in nsMacEventHandler::HandleOSEvent(EventRecord &)
 #46  0x02827380 in nsMacWindow::HandleOSEvent(EventRecord &)
 #47  0x0282c184 in 
DispatchOSEvent__16nsMacMessageSinkFR11EventRecordP15OpaqueW
in
 #48  0x028305a0 in 
DispatchOSEventToRaptor__16nsMacMessagePumpFR11EventRecordP1
5O
 #49  0x0282fc18 in 0x282fc18
 #50  0x0282f86c in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #51  0x0282f54c in nsMacMessagePump::DoMessagePump(void)
 #52  0x0282eddc in nsAppShell::Run(void)
 #53  0x0250a444 in nsAppShellService::Run(void)
 #54  0x0049fd54 in main1(int, char **, nsISupports *)
 #55  0x004a0990 in main

Thread 1:
 #0   0x7000530c in syscall
 #1   0x70557590 in BSD_waitevent
 #2   0x70554a30 in CarbonSelectThreadFunc
 #3   0x70020efc in _pthread_body

Thread 2:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x705594ac in CarbonOperationThreadFunc
 #3   0x70020efc in _pthread_body

Thread 3:
 #0   0x70043988 in semaphore_timedwait_signal_trap
 #1   0x70043968 in semaphore_timedwait_signal
 #2   0x7003fc38 in _pthread_cond_wait
 #3   0x7028366c in TSWaitOnConditionTimedRelative
 #4   0x7027cf10 in TSWaitOnSemaphoreCommon
 #5   0x702c14c8 in TimerThread
 #6   0x70020efc in _pthread_body

Thread 4:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x702505cc in TSWaitOnCondition
 #3   0x7027cef8 in TSWaitOnSemaphoreCommon
 #4   0x7024386c in AsyncFileThread
 #5   0x70020efc in _pthread_body

Thread 5:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x7055b9b4 in CarbonInetOperThreadFunc
 #3   0x70020efc in _pthread_body


PPC Thread State:
  srr0: 0x02517f50 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000020   lr: 0x02517f34  ctr: 0x00574ad8   mq: 0x00000000
    r0: 0x00000000   r1: 0xbfff9d40   r2: 0x0252d000   r3: 0x00000000
    r4: 0x00000000   r5: 0xafc700a0   r6: 0x00000001   r7: 0x00000001
    r8: 0x00000001   r9: 0x025e505c  r10: 0x04fd8c98  r11: 0x800033fc
   r12: 0x00696a58  r13: 0x00000000  r14: 0x00000036  r15: 0x00063480
   r16: 0x00000001  r17: 0x80160e88  r18: 0x0005fad8  r19: 0x00001a07
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004bc4  r23: 0x70004c58
   r24: 0x7016b214  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0d19400
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x00000000  r31: 0x00000001

**********
Looks just like bug 101554, which is fixed.  Are you sure you're seeing this
with a Sept 28 build?
Assignee: asa → hyatt
Component: Browser-General → Tabbed Browser
Keywords: crash
QA Contact: doronr → blakeross
(Reporter)

Comment 2

17 years ago
Yes, the build number was correct.  The description from the bug you mentioned sounds pretty much like what I saw.  Maybe something makes it break on OS X (I'm also using a dual-processor machine, fwiw) that didn't make it break on Linux?

Comment 3

17 years ago
Dupe

*** This bug has been marked as a duplicate of 101554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
reopening. this appears _after_ the fix for bug 101554 landed
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 101554 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
hyatt, _why_ is this a duplicate?  It occurs with a build that has the fix for
101554 in it!
(Reporter)

Comment 7

17 years ago
it's a dup because bug 101554 has been reopened.  that bug has a much better 
description of the crash than I could give, so I'm happy.
Sh. OK. :) in that case, verified duplicate.  :)
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.