Frame numbering incorrect with JavaScript?

VERIFIED DUPLICATE of bug 101746

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 101746
17 years ago
16 years ago

People

(Reporter: Kris Ven, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Problem when visiting http://www.handleidinghtml.nl results in an endless
refresh loop with Mozilla other browser handle it just fine. The URL is
irrelevant to the real problem:

Further investigation leads to the following:
Apparently Mozilla is numbering the frames incorrectly (meaning, different than
other browsers (crosschecked with Netscape 4.78 and Konqueror 2.1)).

See the attached files (testcase & testcase-body). It will show three frames.
One frame will show the content of the parent.frames array. Compare the result
in different browsers.

The parent.frames array has frame3 at position 0 in Mozilla, while in other
browsers frame1 is stored at that location.

Is this due to a different DOM implementation (in that case I think it's not
very good, since it differs from most other browsers), or is it a bug in the
JavaScript engine?
(Reporter)

Comment 1

17 years ago
Created attachment 51473 [details]
Testcase: frameset
(Reporter)

Comment 2

17 years ago
Created attachment 51474 [details]
Testcase: show output
This is a dom bug.

*** This bug has been marked as a duplicate of 101746 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified Duplicate. 
                                                                                    
vk207@bigfoot.com: Thank you for this report. You have been cc'ed
on the other bug so you can follow its progress.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.