Closed Bug 1024678 Opened 6 years ago Closed 6 years ago

Avoid using xmm registers in regexp code

Categories

(Core :: JavaScript Engine: JIT, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: bhackett, Assigned: bhackett)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Floating point registers can't be accessed if the JIT does not support them.  While irregexp never accesses these registers, when external calls are made all volatile registers are pushed, including these registers.
Attachment #8439426 - Flags: review?(jdemooij)
Attachment #8439426 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/7a079e370c33
Assignee: nobody → bhackett1024
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Is this fix going to be pushed down to Aurora 32.0a2?

It looks like crashes I had in Nightly 32.0a1 [involving js::irregexp (e.g. bug #1013586), which were fixed with this patch (Bug) landing], are now occurring in Aurora 32.0a2.

Or, is there a different bug# I should follow for this fix being applied to Aurora?
Comment on attachment 8439426 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 976446
User impact if declined: crashes on older CPUs
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): none
Attachment #8439426 - Flags: approval-mozilla-aurora?
See Also: → 1026134
Comment on attachment 8439426 [details] [diff] [review]
patch

Not serious enough to track, but uplift is low risk and helps with crashes so approving.
Attachment #8439426 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1013589
Blocks: 1026134
Blocks: 1026897
Blocks: 1026896
Blocks: 1026907
Duplicate of this bug: 1027941
You need to log in before you can comment on or make changes to this bug.