Closed Bug 1024724 Opened 6 years ago Closed 5 years ago

Can't install app if Fennec is in Italian

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

All
Android
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: wesj, Unassigned)

Details

(Whiteboard: [WebRuntime])

STR:
Start nightly
Change language to Italian
Go to https://marketplace.firefox.com/app/sketchy/ and install

Results:
After a long pause, you get a "Error parsing manifest" error screen (I think from Android, not us)
"locales": {
        "fa": {
            "name": "Sketchy",
            "description": "\u0628\u0631\u0646\u0627\u0645\u0647\u200c\u06cc \u0631\u0627\u06cc\u06af\u0627\u0646 \u0637\u0631\u0627\u062d\u06cc/\u0646\u0642\u0627\u0634\u06cc"
        },
        "en": {
            "name": "Sketchy",
            "description": "Free Sketch/Paint app"
        }
    }

That description for farsi looks 'sketchy'.
Priority: -- → P1
Whiteboard: [WebRuntime]
Instructions for getting locales working in Fennec: http://160.twinql.com/building-and-testing-multi-locale-firefox-for-android/

Note: I've been unsuccessful at getting this to work so far.
I've installed apps in the marketplace with Firefox for Android in italian without problems.
Maybe this app have some problems in other languages.
Happy to help with this.
OS: Linux → Android
Hardware: x86_64 → All
(In reply to Aaron Train [:aaronmt] from comment #1)

> That description for farsi looks 'sketchy'.

Hurrrrh.

Looks like برنامه‌ی رایگان طراحی/نقاشی, which seems valid to me.

My blind guess at this bug: we fail at this stage if the app doesn't provide a localized name for the selected locale.
Cannot reproduce this with current fx-team.
Wes: what version of Android? I'm testing on 4.4.mumble.
Flags: needinfo?(wjohnston)
I was on 4.3.2 at the time (Verizon, US Galaxy S3). My phone has updated to 4.4 since though (and this works now).
Flags: needinfo?(wjohnston)
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.