After update from v 29.0.1 to v 30.0 the site: https://home.cgm-life.de/fb363286-e393-4a31-84c1-9c60e07c6cef cannot be reached (responsive design - twitter bootstrap - Angular JS)

RESOLVED FIXED

Status

()

Core
DOM
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: stefan.olschewski, Unassigned)

Tracking

({dev-doc-complete, regression, site-compat})

30 Branch
x86_64
Windows 7
dev-doc-complete, regression, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30- wontfix, firefox31 fixed, firefox32 unaffected, firefox33 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8439752 [details]
before after.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

After update from Firefox v 29.0.1 to v 30.0 I tried to open the following web application:

https://home.cgm-life.de/fb363286-e393-4a31-84c1-9c60e07c6cef




Actual results:

With v 29.0.1 the content was displayed correct, with v 30.0 only the background is loaded.


Expected results:

The page should be depicted the same way with v 30.0 like with v 29.0.1 (or prior versions.)

We do use responsive-design with "Twitter Bootstrap", the application is build with AngularJS.

The application worked with several previous versions of Firefox properly.
(Reporter)

Updated

4 years ago
Severity: normal → blocker
Component: General → General
Priority: -- → P1
Product: Core → Firefox

Comment 1

4 years ago
for https://home.cgm-life.de/fb363286-e393-4a31-84c1-9c60e07c6cef.
Fx30.0 got "TypeError: console is undefined" at portal:338 and the blank page.
Fx31b1 & 32a1 is works fine.
Upcoming fix?
Severity: blocker → normal
Priority: P1 → --
Console says:
TypeError: console is undefined


    console.log(l_lang);
    document.write('<script src="components/angular-i18n/angular-locale_' + angular.lowercase(l_lang) + '.js"><\/script>');

    angular.element(document).ready(function ()
    {
        angular.bootstrap(document, ['cgmApp']);
        // Fix to run E2E tests. This is a known issue
        document.body.setAttribute('ng-app', 'App');
    });

-> related to bug 965860/Bug 1024806?
Component: General → DOM
Keywords: regression
Product: Firefox → Core
Version: unspecified → 30 Branch
Yes.  The script on https://home.cgm-life.de/fb363286-e393-4a31-84c1-9c60e07c6cef has this bit at toplevel, with some parts elided:

    if (navigator.userLanguage) // Explorer
    {
        l_lang = navigator.userLanguage;
        var console = {
           // stuff here to have a log function, etc
        };
    }
    else if (navigator.language) // FF
    {
        l_lang = navigator.language;
    }
    else {
        l_lang = "en-us";
    }

Since this is not inside a function and var declarations are hoisted, this ends up shadowing window.console with "undefined".

So really, the same thing as bug 1024806 but on a different site.
Blocks: 965860
Status: UNCONFIRMED → NEW
Ever confirmed: true
To be clear, this is directly on the page, not in any of the libraries it loads, in terms of how widespread that sort of thing would be.
tracking-firefox30: --- → ?
status-firefox30: --- → affected
status-firefox31: --- → unaffected
status-firefox32: --- → unaffected
status-firefox33: --- → unaffected
OK, but this IS an issue for b2g30, so we may want a fix there.
blocking-b2g: --- → 1.4?

Updated

4 years ago
Keywords: dev-doc-needed, site-compat
Added to the site compat doc:
https://developer.mozilla.org/en-US/Firefox/Releases/30/Site_Compatibility#JavaScript
Keywords: dev-doc-needed → dev-doc-complete
(Reporter)

Comment 7

4 years ago
Can we do some code-changes on our site to get it working with v 30.0?
Yes!  Change the code in comment 3 to use "window.console = { stuff }" instead of "var console = { stuff }".  Then you will only change the value of window.console in browsers that have navigator.userLanguage, which is what you're probably aiming for.

Or better yet, only change window.console if !window.console instead of coupling it to the userLanguage stuff.
So basically:

  if (!window.console) {
    window.console = { stuff };
  }
Blocks: 976920
(Reporter)

Comment 10

4 years ago
Thank you very much.
Do you know a concrete date when a bugfix for v 30.0 will be delivered?
When 31 ships, in about 4.5 weeks.
More precisely, the bugfix will be to upgrade to 31.
Since there is a site workaround, this is not a driver for a 30 chemspill and we'll see the fix ship in 31.
tracking-firefox30: ? → -

Updated

4 years ago
blocking-b2g: 1.4? → ---
Ritu, what flags do we need to set to note when this was fixed?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(rkothari)
Resolution: --- → FIXED

Updated

2 years ago
status-firefox30: affected → wontfix
status-firefox31: unaffected → fixed
Flags: needinfo?(rkothari)
You need to log in before you can comment on or make changes to this bug.