Sending mail slow with large "Sent" folder

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: marcus, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I had 1091 mails in my sent-folder (abot 81MB) and sending mail went really
slow, it took about 1 minute until the mail was sent. I had to move all mails to
another folder I had to create, and then sending mail was fast again. 
I think there should be some optimizing on the database routines, because I dont
think I am the only one who leaves all sent mails in this folder (you never
know, when you need this mails in future).

Comment 1

17 years ago
sure is slow...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
QA Contact: esther → sheelar
Build date? Size of the message? IMAP or POP3?

Have you tried with the same profile on 4.x?  How long does that take, for the
same exact message?  While we have performance problems in other areas, I
believe our networking code is quite efficient.

Also, please read this http://www.mozilla.org/quality/bug-writing-guidelines.html.

Thanks for reporting bugs!
(Reporter)

Comment 3

17 years ago
Mozilla build: 2001091303 for Win32

I did not try this with Netscape 4.x, because I don't use Netscape 4.x

The size of the message is not important, and I don't think, this is a problem
with the networking routines.

The problem:
I think the problem is the size of my "Sent" folder: it was about 81MB large,
with 1091 mails in it. When I sent a mail (this could be a mail, that just
contained a "Hello" and nothing else), the progress-window popped up, and the
progress bar showed 100% very fast. After that it took about 1 minute until the
progress window disappeared and I could use Mozilla again (first I thought it
crashed, but it always came back after 1 minute). Within this minute there was a
lot of harddisk activity.

Expected behaviour:
When sending the mail is finished, the mail should be saved fast and the
progress window should disappear fast.

Workaround:
When the "Sent"-folder is too large, move all mail into another folder (call it
"old Sent-Mail" or something like that) and compact the "Sent"-folder. After
this, the sent mail is saved fast in the folder.

I hope this report makes clear, what the problem is.
(Assignee)

Comment 4

17 years ago
Is it every message that takes a long time to send, or the first message in a
session? My guess is that we're reparsing your sent mail folder for some reason,
to recreate the database, and that's what's slow. Why your sent mail folder db
got out of sync is another question.
Status: NEW → ASSIGNED

Comment 5

17 years ago
I have my local sent folder which is 144MB in size and also 5000+ messages.  I
am not seeing any slow down while copying to the sent folder. Since the reporter
said the size of the message does not matter I did send small messages.  
Reporter,
Are you copying messages to imap sent folder or local sent folder?
(Reporter)

Comment 6

17 years ago
I am saving to local folders. 
As I said before, I moved all messages from the original sent folder to another
local folder. Displaying any mail in this new folder is also very slow, it takes
up to 1 minute until a selected message is displayed.
My computer is a Toshiba notebook and not a desktop computer, maybe the speed of
the harddisk is one reason for the decrease of speed while displaying a message.
But it all went slow from one minute to the other as the messagecount in the
folder exceeded 1000 (or 1024, I really don't know, it's just a guess).

Comment 7

17 years ago
Reporter, 
From your comments it appears as though this is could be a system specific
issue.  Can you give us more information on your system?  May be I could get
hold of a machine in the lab with some similar configuration and see if I can
reproduce this problem. 
(Reporter)

Comment 8

17 years ago
My machine is a Toshiba Sattelite Pro 4360 with:
- Pentium III 700 MHz-
- 320 MB RAM
- 12 GB Harddisk Toshiba MK1214GAP
- Windows 2000 SP2

But I am not really shure if it is a problem of my machine: Until I had more
than 1000 mails in the folder, everything went smooth (accessing mails in other
folders is fast, I have folders that contain more than 600 mails, access is fast
within this folders).
I think that the slow harddrive in my notebook is the reason for the early
appearance of this problem. I gues that desktop computers with faster harddrives
will also run into this problem, but with bigger folders (if you know what I
mean, english is not really the language taht I use all day.)
I will check this on my desktop with exactly the same profile as on my notebook
and will report it here.

Comment 9

17 years ago
I too have the problem....

Win2K, 256 Mb Ram, Dual 800 PIII, Build 2001100403

Using IMAP and copying sent messages to "Sent" on my main IMAP Account.

Description:
When I send a message, it gets delivered almost immediately (depending on the
size), then copying the message to the sent folder can take up to a minute.  I
too have a large Sent Folder - and this will not be changing in the near future.
 This used to be very snappy and then regressed.  I'm not sure when this was but
I can try some old builds and see.

From a laymens perspective, it appears that it is now for some reason traversing
the contents of the folder rather than just issuing a IMAP move command.
(Assignee)

Comment 10

17 years ago
I'll ask again: Is it every message send that causes this problem, or just the
first? I.e., if you send a message,and it takes a minute, and then immediately
compose and send another message, does that also take a minute, or is it faster?
Could one of you who sees this problem try an experiment? Shut down the app,
move away the file Sent.msf to a different directory, start up, open the sent
folder, wait for it to reparse, then compose and send another message. Does that
send take a minute or is fast?

Comment 11

17 years ago
Thanks for the clarification.  I tried the test.

I completely shut down Mozilla, removed the Sent.msf from my IMAP directory and
then restarted.  The initial e-mail I created was slow and took about 30 seconds
to copy to the Sent folder.  I saw no reduction on the time involved in copying
to the Sent folder on subsequent messages.  I will now test this on a new profile.
(Assignee)

Comment 12

17 years ago
IMAP directory? Your sent mail folder is on the imap server? The reporter's sent
mail folder is local, I think, though he didn't explicitly say that (I'm just
guessing because he knew the size of his folder). If so, that would mean the
problem is different than I was thinking. I have a 6000 msg sent mail folder on
an imap server and no performance problem. What kind of imap server are you
using? If UW, what mbox format is it? How long does it take to open the sent
mail folder from the UI?

Comment 13

17 years ago
My Second Test....

I created a new Mozilla Profile in which I set access to the same IMAP account.
 I kept all settings the same including the "copy to sent folder on
IMAP_Account".  I then proceeded to send a number of messages.  All messages
required about 45 seconds to be copied to the Sent folder on the IMAP_Account.

As you mentioned, this could be a problem with the IMAP Account so... To ensure
this isn't a problem, I set up a similar account in Outlook express.  Here,
copying the message to my sent folder on the IMAP_Account proceeded without a delay.
(Assignee)

Comment 14

17 years ago
Could you try just opening the imap folder in the UI and see how long that
takes? Outlook Express cheats and claims to have succeeded long before it
actually has, in some situations (you can pull out your network connection and
outlook express will claim to have succeeded in some situations!).

Comment 15

17 years ago
I have 2447 messages in my sent folder ( I took a few thousand out hoping that
would help).  Opening the Sent folder for the first time in a new profile takes
about a minute and I can observe the progress in the status bar.  All subsequent
times opening the Sent folder only take a fraction of a second even if there are
new messages since the last time I opened it.

If you are right and the reporter of the bug was concerned with a local folder,
this could be a different issue  (but an issue none the less!).  I don't want to
sidetrach his bug.
(Assignee)

Comment 16

17 years ago
when you say "every subsequent time", do you mean during that session of the
app, or after shutting down the app and restarting? We cache a connection to the
sent mail folder if you open it, so opening it again in the same session should
be instantaneous, but if you shut down, obviously, we don't keep a connection open.

Comment 17

17 years ago
When shutting down completely and starting another session, it takes about 10
seconds to load the Sent folder the first time.  All subsequent times within
that session require no time to open the Sent folder.

Some more interesting stuff...

I tried the same things in the following milestones with these results:

Mozilla 0.9 -> worked.  Message Copied to Sent folder in about 2 seconds
Mozilla 0.9.2 -> Slow.  Message Copied to Sent folder in about 30 seconds
Mozilla 2001100403 -> Slow. Message Copied to Sent folder in about 30 seconds

Comment 18

17 years ago
Mozilla 0.9.1 -> worked.  Message sent to Sent folder in about 2 seconds.

Comment 19

17 years ago
I did some more testing on the 0.9.1 and 0.9.2 builds to confirm that it was
between those 2 milestones that the copy to Sent (at least with IMAP), became
VERY slow.  I presume one could test the actuall builds during that period and
find the day and narrow it down that way.  Is there a way to access the daily
builds from that far back?

- On Mozilla 0.9.1 Copy to sent was most often instant and at the most 2 seconds.

- On Mozilla 0.9.2 Copy to sent was most often VERY slow at the quickest 20
seconds and up to 1 minute.
(Reporter)

Comment 20

17 years ago
First: all my folders are local! Every sent mail was stored slowly, not only the
first!

Then I did several things: 
As I told you, I moved all mails from local "Sent" to another folder. After
that, storing sent mail was fast again, but access to the old sent messages in
the new folder was slow.
Then I moved back the old sent messages to the "real" Sent-folder, because I
wanted to check bienvenu's experiment.
After that closed Mozilla and moved Sent.msf to another folder, then started
Mozilla again, opened the sent-folder and waited until the folder was reparsed
(wich took about 90 seconds).
Then I sent two mails and, yeah baby yeah,  every mail was stored really fast
(less than 1 second). 
Groovie! This is really cool man, it seems that there are some daily builds,
that cause such trouble (I think I tested a nightly build with my profile before
this trouble started).

Comment 21

17 years ago
Bienvenu,
As per the initial reporter of this bug this problem has to do with local sent
folder.  
Shawn Neumann another reporter you see is describing problems with imap sent
folder . He should log a new bug for this problem. 
This bug got totally side tracked with the imap sent folder issue too. But this
actually meant for the local sent folder.  And also getting rid of the sent.msf
seems to be working for the inital reporter of the bug.  I see that the issues
got mixed up with another reporter's comments.  
Shawn Neumann,
Can you please log a new bug for the imap issue.  Because verifying two
different issues in the same bug is too confusing.  
So, this bug can be summarized as a bad build or a corrupted profile (rather, an
.msf file)?

Comment 23

17 years ago
I guess it sounds like it.  The reporter's problem seems to be resolved using a
different build.  I guess this bug can be resloved as worksforme for now. 
Reporter,
If you happen to reproduce this in the future builds please reopen.  
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 24

17 years ago
As per your advice, the IMAP bug was posted and can be found at:
http://bugzilla.mozilla.org/show_bug.cgi?id=103936

Sorry - I did not intend to sidetrack this bug!

Comment 25

17 years ago
verified this according to my comments below that the inital problem was with 
pop and was resloved after creating a new profile. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.