Closed Bug 1024951 Opened 7 years ago Closed 7 years ago

[NFC] Dialer screenshot shows on shrink UI when try to share contact if dialer is running on the background

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: ashiue, Assigned: gweng)

References

Details

Attachments

(4 files)

Attached image S__1409026.jpg
Gaia      a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/0293597de41f
BuildID   20140612160201
Version   32.0a2

Two phones with NFC enabled

STR:
1. Launch Contact app
2. Launch Dialer app
3. Open Contact app again (Dialer is running on the background now)
4. Tap two phones together
5. Check the shrinking UI

Expected result:
Shrinking UI shows correctly

Actual result:
Dialer screenshot shows on shrink UI, please refer the attached image
blocking-b2g: --- → 2.0?
Product recommendation: Make it 2.0+, it is one of the targeted NFC sharing use cases for 2.0 and sharing contacts is a common use case. This bug shows lack of polish.
triage and per comment 2: 2.0+
blocking-b2g: 2.0? → 2.0+
Component: NFC → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
Well I cannot reproduce.
And from the picture I guess it's due to some async states between NFCmanager/AppWindowManager/shrinkingUI.

Greg, could you take this?
Target Milestone: --- → 2.0 S5 (4july)
OK, I would try to reproduce it and take a look after bugs in my queue got cleared.
Flags: needinfo?(gweng)
Assignee: alive → nobody
Hi Greg, assign this to you first, thanks.
Assignee: nobody → gweng
I can't reproduce it, too. While I follow the STR, it shows another bug that there is no shrinking UI anymore. I'll paste a video to show that as soon as possible.
Flags: needinfo?(gweng)
And I'm pretty sure that the NFC works during the demo, because the devices just vibrate as usual. And I've test Gallery app, it can perform the shrinking animation as expected.
Hi, is the STR unclear since I can always reproduce this issue? I hope this video would give some help.
http://youtu.be/ee7eJhCgLUo
(test build in video: 
Gaia      2248c0367661db9332f70f37055e1a8176f5f612
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/44d31566a3a6
BuildID   20140629160202
Version   32.0a2)
Hmm... I believe I follow the same STR.

The video:

https://www.youtube.com/watch?v=YCfj6odQbQM

I use the first phone daily, so I don't change the homescreen (although they're both with today's Gaia and Gecko). Would we encounter some issue caused by the new Homescreen.
Hi Greg,
I found the different! You need to select a specific contact information to share, because NFC does not share contact at contacts list page.
Sorry for the unclear STR, the more detail steps:

1. Launch Contacts app
2. Click Home button to go back to homescreen (Contacts app is running on the background now)
3. Launch Phone app
4. Click Home button to go back to homescreen (Phone app is running on the background now)
5. Open Contacts app again and select a specific user 
6. Tap 2 phones together 
7. Check the shrinking UI
OK I can finally reproduce it, thanks. Debugging now.
I've found that only Dialer would make the bug occur. Steve says that the only difference between Dialer and other apps, like Clock or Email, is that the Dialer, FTU and Contacts are all sharing the same domain, which would be fixed in the future but at least not now. So I would try to solve the bug according to this approach.
According to Alive's opinion, I'll fix this bug with some workarounds, which may be broken in the future:

1. Shrinking UI would register apps with instance ID instead of manifest URL.
2. Shrinking UI would still filter out those apps without manifest URLs.

1. may be broken if an app has multiple sheet (multiple instance IDs), and one sheet trigger the Shrinking UI

2. may be broken if those apps without manifest URLs needs to be able to support NFC
Attached file Patch
WIP patch because I think the tests may be failed, since I change the way to manage the registry. However, it does works to resolve the bug.
Comment on attachment 8447904 [details] [review]
Patch

It passed all TBPL tests except one reported intermittent error:

https://tbpl.mozilla.org/?rev=6600f0bcfd84197b20d7858a0e4c3d25209dd208&tree=Gaia-Try

So I set review flag now.
Attachment #8447904 - Attachment description: WIP Patch → Patch
Attachment #8447904 - Flags: review?(alive)
OK. The patch pass all master tests:

https://tbpl.mozilla.org/?rev=6600f0bcfd84197b20d7858a0e4c3d25209dd208&tree=Gaia-Try

I'll submit a 2.0 patch ASAP.
Attached file Patch for v2.0
Comment on attachment 8447904 [details] [review]
Patch

r+ with nit
Attachment #8447904 - Flags: review?(alive) → review+
OK, fixed. I think we can fire another bug purely for the test to use mock as you commented. Let's solve the blocker first.
Wait for 2.0 CI result to close this bug.
v2.0: https://github.com/mozilla-b2g/gaia/commit/ba6f32771c65907e2ffd8104504ec5913704807a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified on
Gaia      6b6b7d7fe829ebea85b01aa4ed44cf5ada366bbe
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/9457a67841b3
BuildID   20140703160208
Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.