mozldap pkg-config file generates too many linker options

RESOLVED INVALID

Status

Directory
LDAP C SDK
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: bjoern, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 2014051400

Steps to reproduce:

in the mozldap pkg-config files currently is

Requires: nspr >= 4.10.4 , nss >= 3.16

which leads to the "required" libs also being added to the linker flags, which is not intended for dynamic linking, only for static linking. This is why the "Requires.private" tag should be used in the pkg-config file.

With 

Requires.private: nspr >= 4.10.4 , nss >= 3.16

we get:

# pkg-config --libs  mozldap
-lssldap60 -lprldap60 -lldap60

# pkg-config --libs --static mozldap 
-lssldap60 -lprldap60 -lldap60 -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4

what we really want to get back.

Comment 1

3 years ago
I don't know which files you're referring to.

Can you please provide more information to which files you are referring? In which source control system, on which path, are the files that you want to change?
(Reporter)

Comment 2

3 years ago
those pkg-config files don't come from upstream, they came from the distribution package. Closing this bug accordingly. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.