Closed Bug 1025309 Opened 6 years ago Closed 6 years ago

FxA does not fire onlogout for FMD

Categories

(Firefox OS Graveyard :: FxA, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v2.0 verified, b2g-v2.1 verified)

RESOLVED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: spenrose, Assigned: spenrose)

References

Details

(Whiteboard: ft:loop)

Attachments

(2 files, 1 obsolete file)

From https://bugzilla.mozilla.org/show_bug.cgi?id=1000323#c18 :

"STR:
1) Go to Settings > Firefox Accounts
2) Log in
3) Go back, enter Find My Device, notice how it properly shows the Enable/Disable switch
4) Go back to Firefox Accounts
5) Log out
6) Go back to Find My Device, notice how it still shows the Enable/Disable switch

In step 6, we should see the login button in FMD, which is displayed when onlogout fires. Also, FMD logs a message to the console whenever onlogin/onlogout fires, and that message is not logged for logout -- which further indicates that onlogout is not being fired.

Note, however, that if you close the Settings app, reopen it and go to Find My Device, that will cause a new call to navigator.mozId.request() to be made, which successfully fires onlogout then."
blocking-b2g: --- → 2.0?
Attached patch 1025309-onlgout-fmd.patch (obsolete) — Splinter Review
Hi Jed: a simple patch to add a missing event volley. Thanks!
Attachment #8441123 - Flags: review?(jparsons)
Comment on attachment 8441123 [details] [diff] [review]
1025309-onlgout-fmd.patch

Review of attachment 8441123 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!  Thanks, Sam.
Attachment #8441123 - Flags: review?(jparsons) → review+
Keywords: checkin-needed
Whiteboard: ft:loop
blocking-b2g: 2.0? → 2.0+
https://hg.mozilla.org/mozilla-central/rev/1d2f78d76197
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8441531 [details] [diff] [review]
1025309-onlgout-fmd.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): [this bug]
User impact if declined: weakened FMD security, Marketplace functionality
Testing completed (on m-c, etc.): 
https://tbpl.mozilla.org/?tree=Try&rev=685731972f01
Risk to taking this patch (and alternatives if risky): unanticipated bugs
String or IDL/UUID changes made by this patch:None
Attachment #8441531 - Flags: approval-mozilla-aurora?
Attachment #8441531 - Flags: approval-mozilla-aurora?
Attached video VIDEO0141.mp4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        3aa0797c111a40e36f722722309668de3d469181
Gecko-Rev       93efc8b4155f0a4a50eaad19acbb95ec24139e63
Build-ID        20141204050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.