Absolute paths prevent profile transplantation: prefs.js and panacea.dat

VERIFIED DUPLICATE of bug 12911

Status

MailNews Core
Backend
VERIFIED DUPLICATE of bug 12911
17 years ago
10 years ago

People

(Reporter: gerv, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It is extremely useful to be able to copy the contents of a profile from one
.slt directory to another, and have it Just Work. I need to do this when my
profile get damaged in some way. Ideally, all the paths stored in the files
inside the profiles should be relative. However, mail stores absolute paths in
the following places:

a) Throughout the file panacea.dat

b) In the following pref keys:
mail.directory
mail.imap.root_dir
mail.newsrc_root
mail.root.imap
mail.root.nntp
mail.root.none
news.directory
mail.server.serverX.directory
mail.server.serverX.newsrc.file
(for multiple values of X)

CCing shaver, as I seem to remember him saying that always using relative paths
was a goal.

Gerv

*** This bug has been marked as a duplicate of 12911 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe. if this isn't a dupe of that bug, it's a dupe of bug 99030 which is
currently a dupe of that bug.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.