Image in table not displayed

RESOLVED DUPLICATE of bug 41924

Status

()

RESOLVED DUPLICATE of bug 41924
17 years ago
17 years ago

People

(Reporter: jan.h.d, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010928
BuildID:    2001092808

In the URL
http://store.apple.com/020-1209971/WebObjects/swedenstore/
there is a table that looks like this:

   Pict | Pict
   ------------
   Pict | Pict

The horizontal and vertical lines is an image (1 pixel wide) inside a <td>.
Mozilla displays the alt text "Image" instead of the image (GIF).
However, during loading (I have a slow connection :-) one can
see that the image is indeed displayed as intended, but gets changed
to the text "Image" near the end of the load.


Reproducible: Always
Steps to Reproduce:
1.Go to http://store.apple.com/020-1209971/WebObjects/swedenstore/
2.Watch the text "Image" on gray backround instead of a thin line.

Comment 1

17 years ago
Typing http://store.apple.com/Catalog/se/Images/hp_graypixel.gif into the url
bar (that's the src for the image) results in a Not Found message.  It looks
like it's just a broken img src, and thus Mozilla is displaying the alt text
(alt=Image), as intended. As I understand it this is an accessibility feature,
not a bug.

Over to layout (unsure where this belongs, but definitely not HTML Tables) for
confirmation.
Assignee: karnaze → attinasi
Component: HTMLTables → Layout
QA Contact: amar → petersen
(Assignee)

Comment 2

17 years ago
Yes, the missing image is causing the alt text to appear, but we then do NOT
honor the width constrants on the image. This is all covered elsewhere - bug
41924 has loads of information on how Alt text should be handled. Marking a dup
of that for lack of a better alternative.

*** This bug has been marked as a duplicate of 41924 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.