crash in java.lang.NullPointerException: at org.mozilla.gecko.tabspanel.RemoteTabsVerificationPanel.onFinishInflate(RemoteTabsVerificationPanel.java)

RESOLVED DUPLICATE of bug 1024778

Status

()

--
critical
RESOLVED DUPLICATE of bug 1024778
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: mcomella)

Tracking

({crash})

33 Branch
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox33 affected, fennec33+)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-a0e5e8aa-8828-4c60-a6a8-160f62140613.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.tabspanel.RemoteTabsVerificationPanel.onFinishInflate(RemoteTabsVerificationPanel.java:42)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:763)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:492)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:397)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:353)
	at org.mozilla.gecko.tabspanel.RemoteTabsPanel.updateCurrentPanel(RemoteTabsPanel.java:75)
	at org.mozilla.gecko.tabspanel.RemoteTabsPanel.<init>(RemoteTabsPanel.java:38)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at android.view.LayoutInflater.createView(LayoutInflater.java:594)
	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:696)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:755)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:758)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:462)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:397)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:353)
	at org.mozilla.gecko.tabspanel.TabsPanel.<init>(TabsPanel.java:94)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at android.view.LayoutInflater.createView(LayoutInflater.java:594)
	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:696)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:469)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:397)
	at android.view.ViewStub.inflate(ViewStub.java:259)
	at org.mozilla.gecko.BrowserApp.ensureTabsPanelExists(BrowserApp.java:1376)
	at org.mozilla.gecko.BrowserApp.access$1600(BrowserApp.java:114)
	at org.mozilla.gecko.BrowserApp$28.run(BrowserApp.java:1283)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:157)
	at android.app.ActivityThread.main(ActivityThread.java:5872)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:674)
	at dalvik.system.NativeStart.main(Native Method)

Bug 1024778?
(In reply to Aaron Train [:aaronmt] from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-a0e5e8aa-8828-4c60-a6a8-160f62140613.
> =============================================================
> 
> java.lang.NullPointerException
> 	at
> org.mozilla.gecko.tabspanel.RemoteTabsVerificationPanel.
> onFinishInflate(RemoteTabsVerificationPanel.java:42)

Assuming the code hasn't drifted, this means we can't find the containing layout.  That's... odd.

<snip>

> Bug 1024778?

More or less.
This was fixed in bug 1024778 part 1 and I can no longer reproduce locally on the 6/16 nightly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024778
tracking-fennec: ? → 33+
You need to log in before you can comment on or make changes to this bug.