UI telemetry for opening pages in new tabs from web content contextmenu

RESOLVED FIXED in Firefox 31

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rnewman, Assigned: mfinkle)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 33
All
Android
Points:
---

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed, firefox33 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
09:43:17 <@mfinkle> we still don't cover loading urls via "open in new/private tab" from web context menu

Let's get it done!
(Assignee)

Updated

4 years ago
Summary: UI telemetry for opening pages in new tabs → UI telemetry for opening pages in new tabs from web content menu
(Assignee)

Updated

4 years ago
Summary: UI telemetry for opening pages in new tabs from web content menu → UI telemetry for opening pages in new tabs from web content contextmenu
Created attachment 8440812 [details] [diff] [review]
uitelemetry-loadurl-webcontext v0.1

Uses the same scheme we use in other loadurl telemetry
Assignee: nobody → mark.finkle
Attachment #8440812 - Flags: review?(liuche)
Comment on attachment 8440812 [details] [diff] [review]
uitelemetry-loadurl-webcontext v0.1

Review of attachment 8440812 [details] [diff] [review]:
-----------------------------------------------------------------

One comment, o/w lgtm!

::: mobile/android/chrome/content/browser.js
@@ +502,5 @@
>  
>      NativeWindow.contextmenus.add(Strings.browser.GetStringFromName("contextmenu.openInPrivateTab"),
>        NativeWindow.contextmenus.linkOpenableContext,
>        function(aTarget) {
> +        UITelemetry.addEvent("loadurl.1", "contextmenu", null);

I'd like to see us differentiate between private and non-private tabs, so maybe an extra here (or for consistency/if you're feeling pedantic, extras in both events).
Attachment #8440812 - Flags: review?(liuche) → review+
(In reply to Chenxia Liu [:liuche] from comment #2)
> Comment on attachment 8440812 [details] [diff] [review]
> uitelemetry-loadurl-webcontext v0.1
> 
> Review of attachment 8440812 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> One comment, o/w lgtm!
> 
> ::: mobile/android/chrome/content/browser.js
> @@ +502,5 @@
> >  
> >      NativeWindow.contextmenus.add(Strings.browser.GetStringFromName("contextmenu.openInPrivateTab"),
> >        NativeWindow.contextmenus.linkOpenableContext,
> >        function(aTarget) {
> > +        UITelemetry.addEvent("loadurl.1", "contextmenu", null);
> 
> I'd like to see us differentiate between private and non-private tabs, so
> maybe an extra here (or for consistency/if you're feeling pedantic, extras
> in both events).

We have the same situation with the home pane context menu. It has "open new" and "open private" actiosn on it. we skipped adding extras to it for tracking normal and private.

We current use "action" for track private tabs, but we could revisit adding extras to the right places for "loadurl". I'll file a different bug for that, since it affects more than this patch.
https://hg.mozilla.org/mozilla-central/rev/f60a7bef4506
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Comment on attachment 8440812 [details] [diff] [review]
uitelemetry-loadurl-webcontext v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Allows collecting more telemetry data
Testing completed (on m-c, etc.): Working on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8440812 - Flags: approval-mozilla-beta?
Attachment #8440812 - Flags: approval-mozilla-aurora?
status-firefox31: --- → affected
status-firefox32: --- → affected
status-firefox33: --- → fixed
Attachment #8440812 - Flags: approval-mozilla-beta?
Attachment #8440812 - Flags: approval-mozilla-beta+
Attachment #8440812 - Flags: approval-mozilla-aurora?
Attachment #8440812 - Flags: approval-mozilla-aurora+

Comment 7

4 years ago
remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/122393de469c
status-firefox32: affected → fixed

Comment 8

4 years ago
remote:   https://hg.mozilla.org/releases/mozilla-beta/rev/4de57e02872e
status-firefox31: affected → fixed
You need to log in before you can comment on or make changes to this bug.