[User Story] Skip time and timezone setting when network time available

VERIFIED FIXED in 2.1 S2 (15aug)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: pdol, Assigned: tedders1)

Tracking

({feature})

unspecified
2.1 S2 (15aug)
x86
macOS
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.1, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [ucid:System211], [systemsfe][tako][2.1-feature-qa+])

User Story

As a user I don't want to have to set the time and timezone on my new device if it can be provided by the network so that I can use my device quicker.

Acceptance Criteria:
1. During FTE if the time/timezone is successfully determine from the network, the time/timezone selection is not shown.
2. During FTE if the time/timezone cannot be determined from the network, the time/timezone selection is shown.

Attachments

(1 attachment, 1 obsolete attachment)

No description provided.
User Story: (updated)
Blocks: 1015338
Fernando, how difficult is this?
Flags: needinfo?(fernando.campo)
Not an expert on the matter, as all the developing of the timezone selection was made by Kaze, but after looking at the code I'd say it would be easy. 

Right now we check for the MCC/MNC combination to guess the timezone, and if we don't have it, fallback to America/New York. We could just show the screen if at the end of the process we end up with the default value.

I'd need to do some tests to check if the approach works, as we've had a lot of problems with detection on the past.
Flags: needinfo?(fernando.campo)
See Also: → 826359
Ted is going to take this one.
Assignee: nobody → tclancy
blocking-b2g: backlog → 2.1?
Whiteboard: [ucid:System211], [ft:systemsfe] → [ucid:System211], [systemsfe]
Target Milestone: --- → 2.1 S1 (1aug)
blocking-b2g: 2.1? → ---
Whiteboard: [ucid:System211], [systemsfe] → [ucid:System211], [systemsfe][tako]
Attachment #8463605 - Flags: review?(fernando.campo)
Comment on attachment 8463605 [details] [review]
Bug 1026098 - Skip time and timezone setting when network time available.

I left some comments on the PR, to move the logic to a different place, as we have a function 'skipStep' that we can use instead, so we do all the checks for steps in the same place.

Also, we need tests on this. Please flag me for review when done.

And thanks for taking care of it.
Attachment #8463605 - Flags: review?(fernando.campo)
I added unit tests, and fixed the old unit tests too.
Attachment #8463605 - Attachment is obsolete: true
Attachment #8465057 - Flags: review?(fernando.campo)
Comment on attachment 8465057 [details] [review]
Skip time and timezone setting when network time available.

Left some comments, and a proposal for change. Tell me what do you think about it.
Looking good so far :)
Attachment #8465057 - Flags: review?(fernando.campo) → feedback+
Attachment #8465057 - Flags: review?(fernando.campo)
Thanks, Fernando. I've made the changes you suggested.
Comment on attachment 8465057 [details] [review]
Skip time and timezone setting when network time available.

Looks great, thanks a lot!

Only comment left is to change 'SOURCE' variable to lowercase, linter is failing and patch doesn't work with that. I tested it after changing it, and works like a charm.

Merge whenever TBPL is happy :)
Attachment #8465057 - Flags: review?(fernando.campo) → review+
D'oh! My bad.

Thanks, Fernando :-)
Master: https://github.com/mozilla-b2g/gaia/commit/c35e15354cd18e78b79abd81b999749b326fef16
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Attachment #8465057 - Flags: ui-review?(jsavory)
QA Whiteboard: [2.1-feature-qa+]
Blocks: 1050091
Flags: in-moztrap?(jsmith)
QA Contact: jsmith
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: [ucid:System211], [systemsfe][tako] → [ucid:System211], [systemsfe][tako][2.1-feature-qa+]
Just tried with an up to date build (and gaia commit 254ecd807e539eee0b9a0af409b2f30cbb687fa5), and I can see the Date&Time screen after getting connected to the network. Flame, O2 UK SIM.
https://www.youtube.com/watch?v=y8Dz9jeZjEo

asking for qa to double check, and reopen or create new bug if needed.
Keywords: qawanted
(In reply to Fernando Campo (:fcampo) from comment #13)
> Just tried with an up to date build (and gaia commit
> 254ecd807e539eee0b9a0af409b2f30cbb687fa5), and I can see the Date&Time
> screen after getting connected to the network. Flame, O2 UK SIM.
> https://www.youtube.com/watch?v=y8Dz9jeZjEo
> 
> asking for qa to double check, and reopen or create new bug if needed.

The discussion on bug 1049149 summarizes we are seeing - we do see the timezone screen getting skipped when the network is detected, but the timezone isn't be set correctly. Does that answer your question?

If you are reproducing this with your own SIM, then I think we should open a separate bug for that.
Flags: needinfo?(fernando.campo)
Thanks Jason, I'll open a new bug then, as I am still seeing the screen.
Flags: needinfo?(fernando.campo)
Keywords: qawanted
Flags: in-moztrap?(jsmith) → in-moztrap?(mozbugs.retornam)
QA Contact: jsmith → mozbugs.retornam
Flags: in-moztrap?(mozbugs.retornam) → in-moztrap?(gchang)
QA Contact: mozbugs.retornam → gchang
Add the test cases.
https://moztrap.mozilla.org/manage/cases/?filter-suite=750
Flags: in-moztrap?(gchang) → in-moztrap+
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue is verified fixed on the flame 2.1 (319mb).

Environmental Variables:
Device: Flame Master
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

During FTE, tap 'next' on cellular data screen, the time/timezone selection will not be shown. User can use the device quicker by not setting the time and timezone.

During FTE, 'Enable Data' on cellular data screen, the time/timezone selection is shown.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
After further investigation, The time/timezone selection is always skipped. 
When choosing to not enable data or wifi, the time/timezone selection is still skipped.
The only way to display the time/timezone selection screen is to remove the SIM card before beginning the FTE.
(In reply to Seth Miko [:SethM] from comment #18)
> After further investigation, The time/timezone selection is always skipped. 
> When choosing to not enable data or wifi, the time/timezone selection is
> still skipped.
> The only way to display the time/timezone selection screen is to remove the
> SIM card before beginning the FTE.

Seth, will you please file a new bug for this, and make it block this bug?
Flags: needinfo?(smiko)
(In reply to Michael Henretty [:mhenretty] from comment #19)

> Seth, will you please file a new bug for this, and make it block this bug?

Done: Bug 1063001
Flags: needinfo?(smiko)
Verified fixed. All depends on bugs are verified fixed, invalid, or duplicate.

Actual Result: date & time screen is skipped, when connected to a network. 

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Verified on Flame 2.1 
Actual Result: date & time screen is skipped, when connected to a network.

Flame 2.1

Environmental Variables:
Device: Flame 2.1(319mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1063624
Duplicate of this bug: 826359
Blocks: 915343
Duplicate of this bug: 908627
You need to log in before you can comment on or make changes to this bug.