If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Changing region/city does not update time in settings / FTE

RESOLVED DUPLICATE of bug 1024470

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1024470
3 years ago
3 years ago

People

(Reporter: mushi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8440899 [details]
Time on settings screen does not match time in status bar

Description:

Changing the region or city does not update the time on the screen it was updated from. This is true both for the settings app and FTE. It does update the time in the status bar.

Repro steps:
1. Open Settings > Date & Time
2. Change Region or City to a different time zone and press OK

Actual:
The time row in settings does not show the updated time but the status bar does. 

Expected:
Updated time is shown in the settings screen as well as status bar. 

This is a confusing experience as users will look at the settings screen for feedback related to the changes they made.

Comment 1

3 years ago
I can't get the region to update at all (on latest 2.0 build). New York is the default under America and, after selecting other cities, it still says New York. New selections don't appear to "take."

This is a regression; cities save on earlier builds.
Keywords: regression
This might be a flashing script issue. Let's check:

* 1.4 Flame
* 2.0 Buri
Keywords: qawanted

Updated

3 years ago
QA Contact: jharvey
This bug DOES repro on: Flame 2.1 Master, Buri 2.1 master, OpenC 2.1 Master 

Actual Results: In the Settings page AND in FTU, updating region or city does not update the time shown.

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v121-2
-------------------------------
Environmental Variables:
Device: Buri 2.1 - Master
Build ID: 20140618131634
Gaia: 82e957160ca017087bd374cd051339e55b641e68
Gecko: f78e532e8a10
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v1.2device.cfg
-------------------------------
Environmental Variables:
Device: Open_C 2.1 - Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (2.1 - Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL

-------------------------------------------------------------

-------------------------------------------------------------

This bug does NOT repro on: Flame 2.0, Flame 1.4, Buri 2.0, Buri 1.4, OpenC 2.0, OpenC 1.4

Actual Results: In the Settings page AND in FTU, updating region or city correctly updates the time shown.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
-----------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: v121-2
-----------------------------
Environmental Variables:
Device: Buri 2.0
Build ID: 20140618101436
Gaia: 8e883abdfe32bbbc3934513b4f7cbc0dd7ae3c49
Gecko: 6389357b5981
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
------------------------------
Environmental Variables:
Device: Buri 1.4
Build ID: 20140617095036
Gaia: c6cf82cb56681dbb9ef48cb41fdcd6380da01b26
Gecko: 099f550b87bc
Version: 30.0 (1.4) 
Firmware Version: v1.2device.cfg
-------------------------------
Environmental Variables:
Device: Open_C 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
--------------------------------
Environmental Variables:
Device: Open_C 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: jharvey → croesch
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted

Updated

3 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 3 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1024470
You need to log in before you can comment on or make changes to this bug.