Closed Bug 102618 Opened 23 years ago Closed 11 years ago

quicksearch should support "changed in the last n days"

Categories

(Bugzilla :: Query/Bug List, enhancement, P4)

2.15
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 76498

People

(Reporter: jruderman, Unassigned)

References

Details

Attachments

(2 files)

The QuickSearch feature on the bugzilla front page should allow me to search 
based on when the bug was last changed.  The syntax might be changedin:2 
for "changed in the last 2 days".

I would use this to find bugs that I've just modified, and to limit the number 
of old bugs that show up when I search for a bug about a recent regression.
Attached patch fix #1Splinter Review
This fix is a bit verbose, but it seems to work. Some day, there should be a
generic routine that handles all the different comparison operators and can be
applied to arbitrary fields (with numeric values). But for now, this is probably
good enough.

Taking bug.
Assignee: endico → afranke
Keywords: patch, review
OS: Windows 98 → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.16
-> default owner. (Pulling myself out.)
Assignee: afranke → endico
Without afranke here to drive the patch, we can either just check it in and
hope, or abandon it. Dave?

Gerv
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Of course, I'd prefer it if you just checked it in. Anyway, if you find real
bugs in my code (not limitations or missing features) then mail me directly (not
via bugzilla) and I'll fix it.

If you have any questions about this patch, please let me know.
Since bug 70907 is already so far, I don't think we should bother with this
Javascript patch anymore (although it's not even totally rotten yet). So we need
a perl patch after the quicksearch module is ready.

I'm marking the dependencies per my previous assumptions. If someone disagrees,
please change them.
Depends on: 70907
Keywords: review
Because Bug 70907 is still not FIXED yet, here our local modifications which
are based on attachment 52193 [details] [diff] [review].
[sry for possible bad programming style, this was my very first JS-hack ;-)]

+ Numeric comparison logic moved to more general routine add_num_cmp()
+ New operators == and !=.
+ "chg" is an alias for "changedin"
+ ">xx" is a shortcut for "changedin>xx"
  (may be disabled by setting "changedin_shortcut" to false)

quicksearch.js should IMO be left in the codebase (at least in "contrib") even
after Bug 70907 is fixed, because it is a good base for (client-)local hacks.
After the fixing of bug 37749, changedin should not be used any more; use
chfieldfrom with relative dates instead.
Changedin should still be added to QuickSearch.  Telling QuickSearch users "use
Changedafter with a number of days instead of a date" instead of making
Changedin work would be silly.
Assignee: endico → nobody
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
The trunk is now frozen to prepare Bugzilla 2.22. Enhancement bugs are retargetted to 2.24.
Target Milestone: Bugzilla 2.22 → Bugzilla 2.24
QA Contact: mattyt-bugzilla → default-qa
We are freezing the code for 3.0 in two weeks and we don't expect this bug to be fixed on time.
Target Milestone: Bugzilla 3.0 → ---
Priority: P2 → P4
Assignee: nobody → query-and-buglist
Will be fixed as part of the duplicate bug.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: