Closed Bug 1026265 Opened 6 years ago Closed 6 years ago

[Datastore] JavaScript Error: "this.children[i].window is undefined" {file: "resource://gre/modules/DataStoreChangeNotifier.jsm" line: 117}

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox31 --- unaffected
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: kgrandon, Assigned: baku)

References

Details

Attachments

(1 file)

I'm still not entirely sure of reproduction steps, but we are occasionally seeing this message in logs.

I don't have any STR unfortunately. Gecko build is believed to be a nightly build from 6/16/2014.
Andrea - Could this be bad if we've see this in the logs occasionally?
Flags: needinfo?(amarchesini)
See Also: → 1025441
Attached patch bug.patchSplinter Review
https://tbpl.mozilla.org/?tree=Try&rev=1da81d1d98c6
Attachment #8441199 - Flags: review?(ehsan)
Flags: needinfo?(amarchesini)
See Also: 1025441
Comment on attachment 8441199 [details] [diff] [review]
bug.patch

Review of attachment 8441199 [details] [diff] [review]:
-----------------------------------------------------------------

I hate JS! :-)
Attachment #8441199 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/76486dd239b0
Assignee: nobody → amarchesini
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Do we need to request uplift of this?
Comment on attachment 8441199 [details] [diff] [review]
bug.patch

Bug caused by (feature/regressing bug #): Unknown.
User impact if declined: This could potentially break the vertical homescreen.
Testing completed (on m-c, etc.): Lots of manual testing and verification on master.
Risk to taking this patch (and alternatives if risky): None. This is a one character change. 
String or IDL/UUID changes made by this patch: None.

This is needed for the vertical homescreen. Please approve uplift for 2.0.
Attachment #8441199 - Flags: approval-mozilla-aurora?
Andrea, can you write a test for this please?
Flags: needinfo?(amarchesini)
Well.. In theory the test is already there: dom/datastore/tests/test_changes.html  but for some reason I didn't see this error when it runs for e10s.
Flags: needinfo?(amarchesini)
(In reply to Andrea Marchesini (:baku) from comment #9)
> Well.. In theory the test is already there:
> dom/datastore/tests/test_changes.html  but for some reason I didn't see this
> error when it runs for e10s.

That's very surprising?  Is the problem us eating the error message or something?  Or not running this code path at all?
 0:16.06 System JS : ERROR resource://gre/modules/DataStoreChangeNotifier.jsm:117 - TypeError: this.children[i].window is undefined

The error was there but the tests did not throw any exception.
Comment on attachment 8441199 [details] [diff] [review]
bug.patch

Aurora approval granted.
Attachment #8441199 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.