unreadable text while Java plugin is displaying text

RESOLVED DUPLICATE of bug 99047

Status

--
major
RESOLVED DUPLICATE of bug 99047
17 years ago
8 years ago

People

(Reporter: sergeisteshenko, Assigned: joe.chou)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4+) Gecko/20011001
BuildID:    2001100108

The text is displayed as number - which is correct, followed by
characters looking like blue perimeter rectangles instead of real
Cyrillic characters.

Make sure Java plugin is loaded !

Reproducible: Always
Steps to Reproduce:
1.make sure Java plugin is loaded !
2.visit http://sedmoycanal.com
3.watch the text being scrolled in the upper right corner of the
page - it should be obvious.

Actual Results:  Unreadable text is being scrolled by Java plugin

Expected Results:  Readable text should be displayed/scrolled.

The bug was discovered at the same time as bug #102635, the problem
should be seen as one reproduces conditions for bug #102635.

I am not sure whether the component I chose is the right one.

Comment 1

17 years ago
This is an OJI bug. Transferring to that module.
Assignee: ashuk → edburns
Component: Java APIs for DOM → OJI
QA Contact: avm → pmac

Comment 2

17 years ago
Yes, I verified on Linux redhat 6.2 with jre 1.3.0 (branch build: 2001-10-03-04-
0.9.4), on the upper right corner of the page, the texts are un-readable.
However, it works fine on windows 98 with jre 1.3.1 (branch build: 2001-10-05-05-
0.9.4) and netscape 4.x though.

Comment 3

17 years ago
Sergei, I will attach the screenshot demonstrating the fonts and it's ok on
windows 98 with jre 1.3.1 (branch build: 2001-10-09-10-0.9.4). However,
on linux redhat 6.2 with jre (branch build: 2001-10-09-04-0.9.4), the fonts
are incorrect like lot of small squares.

Comment 4

17 years ago
Created attachment 52990 [details]
screenshot to demonstrates the correct fonts on windows 98

Comment 5

17 years ago
Created attachment 52995 [details]
screenshot to demonstrate the incorrect fonts on linux

Comment 6

17 years ago
Sergei, Did you see the same problem like my screenshot on linux?

Comment 7

17 years ago
I think this is not bug of OJI. This is responsibility of java plugin
to display text correctly. I think that it either problem in
configuration (problems with localization and the appropriate font.properties)
or bug in java plugin. I couldn't compel the Mozilla to display text correctly.
I'm going to investigate this problem

Comment 8

17 years ago
I filed bug #4525268 in Bugtraq on java plugin with synopsis:
"java plugin doesn't display non-latin letters". 

Comment 9

17 years ago
Just tried it with 2001111606 under Linux and java 1.3.1-b24, the plugin you are
offered to download. I can see only boxes. ---> NEW

No crash or hang here, so I am lowering the severity to MAJOR.
Severity: critical → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

17 years ago
Text to display is passed as applet's parameters -> dup of 99047

*** This bug has been marked as a duplicate of 99047 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: edburns → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.