Closed Bug 1026450 Opened 7 years ago Closed 7 years ago

Clipped animated transforms trigger layerization of elements outside the clip

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: mstange, Assigned: mstange)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file testcase
STR:
 1. Load the testcase and enable paint flashing.
 2. Move your mouse over the box with the black border.

Expected results: Only the blue box should be layerized and invalidated.
Actual results: The green box is invalidated, too.

Animating the blue box causes the green box to get its own layer because our code thinks that the blue box might move under it. But that's not possible because the blue box is clipped by the black box.
Attached patch v1Splinter Review
Attachment #8441291 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/aba2006f674b
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.