Closed Bug 1026469 Opened 5 years ago Closed 5 years ago

tbpl marks spurious errors about pthread.h

Categories

(Firefox Build System :: General, defect)

All
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla33

People

(Reporter: mjrosenb, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

When there are build errors on windows (particularly, if there is a single error), it can get lost in the noise of multiple highlighted configure errors about missing pthread.h
OS: Linux → Windows 7
Hardware: x86_64 → All
Assignee: nobody → mh+mozilla
MOZ_CHECK_PTHREADS was added in 2001, mentioning something about hpux and aix. I'm pretty sure even then, using AC_CHECK_LIB would have been fine.
Attachment #8441855 - Flags: review?(ted)
Same for NSPR.
Attachment #8441856 - Flags: review?(ted)
Another dimension of the problem is that the nspr build system explicitly disables checks when using msvc. Except it only does so when $CC is exactly "cl". Which excludes try, where CC is cl, wrapped with sccache. I'm pretty sure (some) developers are setting CC manually too, to include a full path to cl.
Attachment #8441867 - Flags: review?(ted)
Thank you for doing this :-)
Blocks: log-SnR
Attachment #8441855 - Flags: review?(ted) → review+
Attachment #8441856 - Flags: review?(ted) → review+
Attachment #8441867 - Flags: review?(ted) → review+
Ted, could you land this?
Flags: needinfo?(ted)
I tagged NSPR head as NSPR_4_10_7_BETA1 as well.
https://hg.mozilla.org/mozilla-central/rev/869cfa421fa9
https://hg.mozilla.org/mozilla-central/rev/e7e2e97d2355
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.