If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text in single line can overlap

VERIFIED WORKSFORME

Status

Other Applications
ChatZilla
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Matthew Cline, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 2001100108, Linux 2.4.9 i686, RedHat 6.1, XFree86 4.1.0, KDE 2.1.1

In the Chatzilla display box (the widget where the conversations are being
displayed), if the text on a single line changes color, or it changes font (like
normal to bold), then the changed text is offset back onto the previous text. 
If the text is highlighted, then the problem is fixed somewhat.

Also, the smiley graphics are offest back onto the previous text in the
same manner.
(Reporter)

Comment 1

16 years ago
Actually, that's not the only thing that does it.  For instance,if you say this
on a channel:

    aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb

The list of b's will overlap the a's.  And if you enter this:

    ``````````````````````````````````````````````````` a b c

The back ticks will overlap the "a b c".

Also, changing color or font doesn't seem to have any effect when the font
being used is monospaced.
Summary: Text with different color or font is offset back over previous text → Text in single line can overlap

Comment 2

16 years ago
Probably just a temporary glitch in mozilla or your particular build.
If you still see it with a different build, then reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
Alright, I figured out the problem.  I was using the gdkxft library, which was
transparently adding True Type support to GDK.  Apparently it and the GDK gfx
code don't really get along.  Marking bug as VERIFIED WORKSFORME.

You can find the gdkxft project at http://philrsss.anu.edu.au/~josh/gdkxft
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.