Closed Bug 1026716 Opened 5 years ago Closed 5 years ago

Selecting a search suggestion should update the search field but keep the keyboard on display

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: djabber, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Expected:
If the user selects one of the e.me search suggestions, the search field should update with the selected term and the keyboard should remain on display. See latest Search app spec, ver 0.6, pages 5-6 at: https://mozilla.box.com/s/qbbhcsoaqwqwl9dce4mc

Actual:
The keyboard is dismissed if the user taps a search suggestion.
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Blocks: vertical-home-next
No longer blocks: 1015336
Attached file Github pull request
Attachment #8442772 - Flags: review?(dale)
Comment on attachment 8442772 [details]
Github pull request

This looks and works good, can land with a green test run
Attachment #8442772 - Flags: review?(dale) → review+
Waiting for land.  This would clear up the confusion on when changing the search engine and tapping on a word suggestion as currently it's not doing what's expected ( ie search in the web browser ).
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Merged in master:

https://github.com/crdlc/gaia/commit/e7bb5e30cb57776114e4b336e709b37ae2c78d8d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8442772 [details]
Github pull request

Needed for the vertical homescreen.
Attachment #8442772 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8442772 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Keywords: verifyme
Verified the issue is fixed on 2.2, 2.1 and 2.0,
Keyboard remains on the screen when suggested search is tapped and the screen is updated

Device: Flame 2.2 Master KK
BuildID: 20141027040237
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141027001201
Gaia: c97463d61f45513a2123b19610386ddbfc916819
Gecko: 4f8c0c021128
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Device 2.0 KK
BuildID: 20141027000202
Gaia: 2183b4f3ec0eb47ab1f133c31732ec53b08ad253
Gecko: 43bee45176c4
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] → [VH-FL-blocking-][VH-FC-blocking-], [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-], [QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking-], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.