If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Switching default email clients back to Outlook Express causes MAPI32.DLL swapping to fail.

VERIFIED FIXED

Status

MailNews Core
Simple MAPI
P3
normal
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Trix Supremo, Assigned: Srilatha Moturi)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT], URL)

(Reporter)

Description

16 years ago
If Outlook Express is initially the default, switch the default to Mozilla, and
then go back to Express and make that the default, Mozilla will fail to become
the default email client.  because when you go back to Express and make the
change, a MAPI32_MOZ_BAK.DLL remains so when we try to make a backup of the
MAPI32 to a file that already exists, we fail.
(Assignee)

Comment 1

16 years ago
I checked into the private branch.
(Reporter)

Comment 2

16 years ago
srilatha, is it possible to check to determine what type of mapi file is stored
as the "Mapi32_moz_bak.DLL".  because there are some scenario's where the backup
file is our mapi file and deselect mozilla as the default email client would
just copy our mapi file back.

Comment 3

16 years ago
I think I'm one of those scenario's.   After selecting Mozilla as the MAPI mail
app, I can not get Outlook to become the default.  In fact, Outlook errors when
I try to launch it now with MAPI.  Outlook worked for me until I selected
Mozilla as the default mail app.

Comment 4

16 years ago
sounds like an interesting branch candidate since a couple QA folks have run
into this scenario.
Keywords: nsbranch

Comment 5

16 years ago
I 2nd Scott's comment. This one should get a nsbranch+. Tiantian?
Whiteboard: [PDT]

Comment 6

16 years ago
We already discussed about this in one of the PDT. This is a known problem. 
We'll put the walkaround in user guide, etc.

Updated

16 years ago
Blocks: 103807

Comment 7

16 years ago
Using build 20011008, with mozilla set as the default mail client, try to switch 
back to Outlook Express failed.

The workaround for this (someone may already know) is:

1. De-select mozilla as the default mail client in EDIT|PREFERENCE dialog
2. Two files: mapi32.dll and mapi32_moz_bak.dll should be deleted.
3. Select OE as default mail client in TOOL|OPTION

Now the mapi32.dll file should be created with approx 130K size, and OE should 
be your default mail client again.

Comment 8

16 years ago
What are we going to tell users on this?
(Assignee)

Comment 9

16 years ago
This might not happen in today's build. Can you try today's build.
I could not reproduce this in my debug build.

Comment 10

16 years ago
Fixed in branch.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: vtrunk
Priority: -- → P3
Resolution: --- → FIXED

Comment 11

16 years ago
How was this fixed? We don't see a patch? Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

16 years ago
This is a pretty serious bug. Marking nsbranch+ per Simple MAPI / PDT triage.
Keywords: nsbranch → nsbranch+
(Assignee)

Comment 13

16 years ago
This is fixed by the patch in bug 102308.
Trix can you verify that this is fixed
(Reporter)

Comment 14

16 years ago
verified on 2001-10-12-05-0.9.4 branch build

changing resolution to fixed.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

16 years ago
verified on 2001-10-12-05-0.9.4 branch build

adding vtrunk keyword for regression on trunk build
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.