Closed Bug 1027271 Opened 8 years ago Closed 8 years ago

[Rocketbar] banner becomes transparent occasionally when transitioning to browser

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: nhirata, Assigned: vingtetun)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files)

1. hit power button
2. hit power again
3. unlock the screen
4. tap the rocketbar
5. go to www.google.com
6. hit home
7. tap the rocketbar and hit return again


Expected: black status bar
Actual: transparent status bar

Gaia      83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/55679dc2e72b
BuildID   20140618000202
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
Flame
UX - Is this is a blocker for the visual refresh in 2.0? This appears to happen in multiple places, although this bug is one example of the issue.
Component: Gaia::Search → Gaia::System
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Francis and Peter for a blocking call. My *initial* response is yes but I defer to the owners. :) Nice catch, guys!
Flags: needinfo?(pla)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)
Yes, this is definitely a blocker.  It needs to be found and fixed in every instance.  I'll alert my team to file bugs wherever they notice this.
Flags: needinfo?(pla)
blocking-b2g: --- → 2.0?
I refer readers to comment 5, given by my esteemed colleague, the right honorable Peter La.
Flags: needinfo?(fdjabri)
Whiteboard: [systemsfe]
blocking-b2g: 2.0? → 2.0+
Component: Gaia::System → Gaia::Homescreen
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
I understand the steps and I can see screenshots but I cannot reproduce it in my hamachi and I don't have a flame device. Please Kevin, can you reproduce it on your flame device?
Flags: needinfo?(kgrandon)
(In reply to Cristian Rodriguez (:crdlc) from comment #7)
> I understand the steps and I can see screenshots but I cannot reproduce it
> in my hamachi and I don't have a flame device. Please Kevin, can you
> reproduce it on your flame device?

Can't reproduce on a flame neither.

Naoki, does it happens all the time, or just sometimes, also do you still see it on the flame ?
Flags: needinfo?(kgrandon)
Keywords: qawanted
(In reply to Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) from comment #8)
> (In reply to Cristian Rodriguez (:crdlc) from comment #7)
> > I understand the steps and I can see screenshots but I cannot reproduce it
> > in my hamachi and I don't have a flame device. Please Kevin, can you
> > reproduce it on your flame device?
> 
> Can't reproduce on a flame neither.
> 
> Naoki, does it happens all the time, or just sometimes, also do you still
> see it on the flame ?

I have been able to reproduce it once. Not sure how yet.
Attached patch bug1027271.patchSplinter Review
This patch revert the event from appopening to appopened (the invert was done in bug 1020264) but the fix for bug 1020264 has landed this morning (events were not dispatched on any windows until appopened fired).

I'm not sure if this is the root issue of this bug yet - but it worth landing this patch as it is a clear cause of transparent background, and I have an hard time to reproduce without it.
Attachment #8445167 - Flags: review?(etienne)
Attachment #8445167 - Flags: review?(etienne) → review+
FYI, I respond faster with a needinfo.  :)

It happened a lot more on the build I was using 70 % and in a previous build, I thought it was more 100 %.
It doesn't happen all the time on today's build.  Probably like 30 %

I think it has to do with having a certain number of tabs and timing.

To narrow down the steps, I removed lockscreen and SIM and didn't bother with the power button
STRs:
1. reboot device
2. tap rocketbar
3. type youtube.com
4. once youtube.com is in the browser, hit home
5. tap rocketbar
6. hit return
7. repeat 5 and 6 one or two more times.

I was able to get a transparent bar to reappear.
Oops! Figured out 100 % STR:
1. launch browser
2. tap the URL bar to get you to the awesome page
3. hit home button
4. tap rocketbar
5. type in youtube.com and hit return.
Flags: needinfo?(crdlc)
Flags: needinfo?(21)
Assignee: nobody → 21
Flags: needinfo?(crdlc)
Gaia-try and travis looking good. Going to take this and help land as it was unassigned before.

Thanks for the work on this.

Landed: https://github.com/mozilla-b2g/gaia/commit/c5ff624a02d947730e34085d1bacad5231e01850
Assignee: 21 → kgrandon
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(21)
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S5 (4july)
(In reply to Kevin Grandon :kgrandon from comment #14)
> Gaia-try and travis looking good. Going to take this and help land as it was
> unassigned before.
> 
> Thanks for the work on this.
> 
> Landed:
> https://github.com/mozilla-b2g/gaia/commit/
> c5ff624a02d947730e34085d1bacad5231e01850

What the hell ? You take my patch, unbitrot it and land with your name ? ...
Status: RESOLVED → VERIFIED
Attached image IMAG0548[1].jpg
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f91abc6127d9
Build-ID        20141125000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.