[B2G][Flame][FTE] Alphabet picker does not function

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rpribble, Assigned: gmarty)

Tracking

({regression})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [2.0-flame-test-run-2][systemsfe])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8442454 [details]
Contacts.csv

Description:
The alphabet picker is nonfunctional when trying to scroll through the contact list to import during the FTE. Sometimes the picker will respond intermittently for a few seconds or to taps, but rarely.  This issue occurs in Outlook, Gmail, and Facebook.

Prerequisites: 
Have at least ~20 contacts in an email account (enough to create a scrollable list in the import contact section of the FTE). Import attached Contacts.csv file to your email account if needed.

Repro Steps:
1) Update a Flame to BuildID: 20140618000202
2) Factory reset the device from settings
3) Enable data > Navigate to import contacts screen > log in to Outlook (or Facebook, or Gmail)
4) Attempt to slide or tap the picker on the right hand side to scroll through the contacts list

Actual:
Alphabet picker is not functioning.

Expected:
Alphabet picker can be scrolled and tapped as in contacts and other apps.

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2
Firmware Version: v121-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.

Notes:


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/7267/
See attached: Video, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8442463 [details]
Video.ogg
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
This issue DOES reproduce on Flame 2.1, Buri2.1, Open C 2.1, Flame 2.0, Buri 2.0, and Open C 2.0

Flame 2.1

Environmental Variables:
Device: Flame Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140618073003
Gaia: 336c30b6147cdd9122ad0b2bbffb81eb869a9ec2
Gecko: 1cea544c74c5
Version: 33.0a1 (Master) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140618063014
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 883d156210cf
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Alphabet picker is almost always unresponsive when trying to scroll
_________________________________________________________________________________________

This issue does NOT reproduce on Flame 1.4, Buri 1.4 or Open C 1.4

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140618063004
Gaia: fc74015d26bcbc3e31a45d34cb65777112a35982
Gecko: fab72d8aa2e0
Version: 30.0 (1.4) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Alphabet picker scrolls as expected
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
(Reporter)

Comment 3

4 years ago
Created attachment 8442524 [details]
Logcat.txt
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted, regressionwindow-wanted
Kevin - There's no reason to have a qawanted flag here. Additionally, this is missing a triage decision on the bug.
QA Whiteboard: [QAnalyst-Triage+] → [lead-review-]
Flags: needinfo?(ktucker)
The alphabet bar was functioning properly on 1.4 so this is a regression. This seems like an obvious bug that the end user could encounter with their first time use of the phone so i suggest that this issue is nominated 2.0?
Flags: needinfo?(ktucker)
Keywords: qawanted
(In reply to ktucker from comment #5)
> The alphabet bar was functioning properly on 1.4 so this is a regression.
> This seems like an obvious bug that the end user could encounter with their
> first time use of the phone so i suggest that this issue is nominated 2.0?

If that's the case, then make sure you nominate the bug to block.
Flags: needinfo?(ktucker)
blocking-b2g: --- → 2.0?
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [lead-review-] → [QAnalyst-Triage+][lead-review+]

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
I'm starting to take a look at this today, but if this is a regression, a commit-window would be very helpful to isolate the problem.
Assignee: nobody → fernando.campo
QA Contact: bzumwalt
Humm, I tested it on hamachi device, with the latest from master, and I have this weird situation:
- If I try on the edge (where the shortcuts should work), I get a javascript error on the files edge_swipe_detector.js and stack_manager.js, meaning that is detected as a edge_gesture instead of an in_app_gesture
- If I try a little on the left of the edge (on the limit between the list and the shortcuts), then the shortcuts works as they should.
- Further on the left, the list scrolls (obvious)

Which makes me believe that we are having problem with the gesture detector clashing with the edge gestures, not a direct problem with the alpha scroll.

In the video from comment 1, I think it's only tested with edge gestures, so if QA could confirm this behaviour on other devices and builds, it would be very helpful.

So far I didn't see anything on the code of FTU or contact_shortcuts that can be blamed for this, so if this is really related with edge gestures, we would need to disable those during FTU (anyway those are not useful, as FTU is not stacked, and no other apps are running at the same time).

Updated

4 years ago
QA Contact: bzumwalt → lmauritson

Comment 9

4 years ago
B2G Inbound regression window (Based on comment 8)

Last Working
Device: Flame Master
BuildID: 20140513203003
Gaia: 00809a04b5ec88d0c97d725fdeeba7e3833177de
Gecko: d0930771b30a
Version: 32.0a1 (Master) 
Firmware Version: v122

First Broken
Device: Flame Master
BuildID: 20140513233003
Gaia: e927a832658cf21d3c62efc6359e49d347c4d358
Gecko: c7c8783b9815
Version: 32.0a1 (Master) 
Firmware Version: v122

First_Broken_Gaia_Last_Working_Gecko: Broken
Gaia: e927a832658cf21d3c62efc6359e49d347c4d358
Gecko: d0930771b30a

Last_Working_Gaia_First_Broken_Gecko: Working
Gaia: 00809a04b5ec88d0c97d725fdeeba7e3833177de
Gecko: c7c8783b9815

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/00809a04b5ec88d0c97d725fdeeba7e3833177de...e927a832658cf21d3c62efc6359e49d347c4d358
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
This is a regression from enabling of edge gestures.
Blocks: 918792
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2][systemsfe]

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Updated

4 years ago
Component: Gaia::First Time Experience → Gaia::System::Window Mgmt
Due to comment 9 and comment 10, which confirm my theory, I'm deassigning myself as this is no longer a FTU matter, and there's probably other people better fit to solve this.
Assignee: fernando.campo → nobody
Etienne - Can you take a look? The range indicates this is a regression from edge gestures getting preffed on.
Flags: needinfo?(etienne)
(Assignee)

Updated

4 years ago
Assignee: nobody → gmarty

Updated

4 years ago
Flags: needinfo?(etienne)
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Comment 13

4 years ago
Created attachment 8445875 [details] [review]
Github PR

This PR fixes this issue by deactivating the edge swipe gesture in the FTU.

It emits an event called 'ftuopened' because 'ftuopen' is triggered before 'appopen' that enables edge swipe.
Attachment #8445875 - Flags: review?(etienne)
Comment on attachment 8445875 [details] [review]
Github PR

Hey, I know this is the solution we discussed yesterday, and it works.
But I'm pretty uncomfortable with dispatching ftupopened on appopen and ftuopen on appopened, looks weird.
Also some apps might be launched in the background while the FTU is running and we would enable the edge gestures at this point.

So I think the best fix is to check if |FtuLauncher.isFtuRunning()| in the EdgeSwipeDetector when we get an 'appopen' event, and not set the lifecycleEnabled to true when it's the case.
Attachment #8445875 - Flags: review?(etienne)
(Assignee)

Comment 15

4 years ago
Created attachment 8446500 [details] [review]
Github PR

Here's a new PR with the new logic implemented and the tests fixed.
Attachment #8445875 - Attachment is obsolete: true
Attachment #8446500 - Flags: review?(etienne)
Comment on attachment 8446500 [details] [review]
Github PR

all good, thanks!
Attachment #8446500 - Flags: review?(etienne) → review+
Gmarty,

What's prevent this bug to land? Thanks!
Flags: needinfo?(gmarty)
(Assignee)

Comment 18

4 years ago
Both Travis and TBPL were red on unrelated errors so I rebased yesterday. There are still unrelated failures, but I'll land the patch as soon as the tasks I restarted are over.
Flags: needinfo?(gmarty)
Marking as fixed since it got merged (Comment 19).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
v2.0: https://github.com/mozilla-b2g/gaia/commit/b25c7ce0e5fe47576e5f75e50d37c9dd3204583a
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
You need to log in before you can comment on or make changes to this bug.