Closed Bug 1027463 Opened 5 years ago Closed 5 years ago

Intermittent Marionette-js Test failure - Search apps from Rocketbar

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: rudyl, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

I've seen this failure twice today, e.g.
https://travis-ci.org/mozilla-b2g/gaia/jobs/27845952

=====================
1) Search - App search Search apps from Rocketbar:

JavaScriptError: (17) TypeError: icon.element is null

Remote Stack:

@app://search.gaiamobile.org/shared/elements/gaia_grid/js/grid_view.js, line 146

at Error.MarionetteError (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)

at Object.Client._handleCallback (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)

at /home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21

at TcpSync.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)

at Object.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)

at Object.Client._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)

at Object._executeScript (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1468:19)

at Object.executeAsyncScript (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1249:19)

at Object.Mgmt.getAll (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-apps/lib/mgmt.js:37:19)

at list (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-apps/lib/list.js:14:20)

at getApp (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-apps/lib/getapp.js:45:10)

at switchToApp (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-apps/lib/switchtoapp.js:20:10)

at Object.Search.goToApp (/home/travis/build/mozilla-b2g/gaia/apps/search/test/marionette/lib/search.js:107:34)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/search/test/marionette/app_search_test.js:29:12)

at callFn (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:223:21)

at Test.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:216:7)

at Runner.runTest (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:373:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:451:12

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:298:14)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:308:7

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:246:23)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:270:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at callFn (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:228:7)

at Hook.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:216:7)

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:258:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:270:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:199:9

at Object.executeHook (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:369:18)

at process._tickCallback (node.js:415:13)

--
looks like bug 968040, but the error message is different, so I file this one.
Summary: Intermittent Test failure - Search apps from Rocketbar → Intermittent Marionette-js Test failure - Search apps from Rocketbar
Kevin,

Have you ever seen seem this kind of test error before?
Any clue on why might be the cause?

Thanks.
Flags: needinfo?(kgrandon)
Thanks for filing. Trying to debug this on my travis now: https://github.com/KevinGrandon/gaia/pull/20
Flags: needinfo?(kgrandon)
Dale - could you help us investigate? Might just need a simple if() guard. Thanks!
Flags: needinfo?(dale)
Will take a look at this
Assignee: nobody → dale
Flags: needinfo?(dale)
Yeh clear was being called on this element so it was being removed, hopefully can remove the setTimeout but this should fix the tests for now, they failed for me 100%, its only gonna cause an error after the tests run so assuming its a timing issue
Attachment #8443842 - Flags: review?(kgrandon)
Comment on attachment 8443842 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20837

Makes sense, thanks for tracking that down. Land when green.
Attachment #8443842 - Flags: review?(kgrandon) → review+
hmm, seeing a lot of intermittent fails in the gaia ui tests 

https://travis-ci.org/daleharvey/gaia/jobs/28094293

any ideas whats up zac? gonna look into this but doesnt look related
Flags: needinfo?(zcampbell)
Build seems green, so let's land for now. Ui test issue seem homescreen related, we did have a flurry of landings the other day, so it's highly possible that we changed some behavior and need to fix some waits. I'll look into it, but let's use another bug for investigation.
Flags: needinfo?(zcampbell)
Landed: https://github.com/mozilla-b2g/gaia/commit/6c598e855a7907dd09ab39fc561208f012658abc

Blocking the vertical homescreen so I can track uplift order.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8443842 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20837

This is needed for the vertical homescreen.
Attachment #8443842 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8443842 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S4 (20june)
You need to log in before you can comment on or make changes to this bug.