Closed Bug 10275 Opened 21 years ago Closed 20 years ago

top talkback - M8 - nsCSSFrameConstructor::ConstructTableGroupFrame 3458a42e

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P1)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: chofmann, Assigned: matt)

References

()

Details

If you follow the links on the Call signatures you'll see the several different
test senario's that lead to the same or similar crashes.

Its likely that all/any bugs in the system that contain information about
any of the following can be consolidated down to a single bug
and fix in this area of the code..

Comments in the linked reports show...

Attempting to prewivew skins from the chrome zone section.

Changing themes (previewing) first time went OK, second one crashed.

Performing the test after the toolbar test.

www.mozillazine.org I clicked on "preview" on the first theme, then
maximised the main window (the preview window hadn't opened yet)

Debug|XPToolkit|Tab

I was cruising around www.mozillazine.org/chromezone (whatever the
ChromeZone URL is) and then I tried to go to mozilla.org by pressing
the dragon in the top-right corner. The status bar flashed some stuff, so
it looked like it started loading, but

Select Debug...XpToolkit...Tree. Crash!

I was trying the XUL demos (Debug menu, third item) I had just tried
demo three. I notice that none of the XUL demos in that menu appear
 to be working correctly... :o(
stack trace looks like:

Incident ID 11325936
nsCSSFrameConstructor::ConstructTableGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1249]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 2968]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3861]
nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1692]
nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1664]
nsCSSFrameConstructor::ConstructTableGroupFrameOnly
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line
1331]
nsCSSFrameConstructor::ConstructTableGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1214]
nsCSSFrameConstructor::ConstructTableFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 963]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 2985]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3861]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 756]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 2064]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4339]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 804]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 909]
XULDocumentImpl::StartLayout
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 3984]
XULDocumentImpl::EndLoad
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1867]
CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 308]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 530]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 899]
nsParser::EnableParser [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 618]
CSSLoaderImpl::Cleanup
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 639]
CSSLoaderImpl::SheetComplete
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 709]
CSSLoaderImpl::ParseSheet
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 744]
CSSLoaderImpl::DidLoadStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 774]
DoneLoadingStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 581]
nsUnicharStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\network\module\nsNetStreamLoader.cpp, line 158]
nsDocumentBindInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 2020]
OnStopRequestProxyEvent::HandleEvent
[d:\builds\seamonkey\mozilla\network\module\nsNetThread.cpp, line 594]
StreamListenerProxyEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\network\module\nsNetThread.cpp, line 474]
PL_HandleEvent [plevent.c, line 494]
PL_ProcessPendingEvents [plevent.c, line 455]
_md_EventReceiverProc [plevent.c, line 916]
USER32.dll + 0x1268 (0x77e71268)
nsappshell.dll + 0x1857 (0x60821857)
apprunner.exe + 0x2377 (0x00402377)
KERNEL32.dll + 0x1ba3c (0x77f1ba3c)
Status: NEW → ASSIGNED
Target Milestone: M9
Assignee: karnaze → hyatt
Status: ASSIGNED → NEW
David, I'm assumming that the assertion is being raised because of the new ways
in which nsTableRowGroup is being used by the trees. Could you please comment
the assertions and see if things work ok.
Priority: P3 → P1
Bumping priority to P1, should at least investigate this for M9, since it is a
top talkback issue.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
IT's only happening because people are clicking on the malformed tree widget test

case that is accessible from the menu.  I don't have the time or inclination to

repair all of our XUL test case files.  SOmeone else can do this.
Status: RESOLVED → REOPENED
Assignee: hyatt → don
Status: REOPENED → NEW
who is a good person to help on this?  matt?
better to disable that to create a lot of
noise in the talkback system.
Resolution: WONTFIX → ---
Clearing Won't Fix due to reopen.
Assignee: don → matt
Matt, can you remove or just disable the damn menu item, clear the target
milestone, and re-assign to hyatt?
Assignee: matt → hyatt
Target Milestone: M9 → M10
Took link out
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Then we're done.
Status: RESOLVED → VERIFIED
I called up a page, as it was loading I went to Debug|XPToolkit|Tab and the
secondary panel displayed and continued to work fine. Marking verified
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Reopens since this happens again. Easily reproduced by just running apprunner.
Select from menu: Debug->XPToolKit->Tree and wow. An assertion!

If it's due to a malformed, not working testcase, why don't remove it?
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WONTFIX
I don't have time to mess with malformed XUL test cases.  If someone else wants
to remove it, fine.
Status: RESOLVED → REOPENED
Assignee: hyatt → matt
Status: REOPENED → NEW
matt, can you remove or fix?  thanks
Resolution: WONTFIX → ---
Blocks: 7919
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
taken out
QA Contact: beppe → petersen
Status: RESOLVED → VERIFIED
Based on Matt's comments, marking as verified fixed in the Sept 27th build.
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.