Closed Bug 1027555 Opened 5 years ago Closed 5 years ago

[Vertical Homescreen] No icons on homescreen with DEBUG=1 mode on nightly

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: chens, Assigned: vingtetun)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image Homescreen-no-icon.png
Steps to Reproduce:

1. Build Gaia with DEBUG=1 flag
2. Running Gaia on Nightly

Actual Results:
No icons and app name on homescreen.
	 
Expected Results:
Vertical homescreen with icons and app name

Environment Informations:
- Git commit info: 0517d93acd79a070b11f3e3d576fcc34ef4abdb5
- Platform version: 33.0a1(2014-06-18)/32.0a2(2014-06-18)
I thought it was failing because of the assertions
we can see on startup about Interapp communication xpcom.
But it still fails with this patch... so I'm not sure it is related.
Kevin - A bug like this is a dev blocker, right (i.e. block a developer's daily workflow from doing their job)?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Flags: needinfo?(kgrandon)
Yup, it's pretty painful and we should definitely try to fix it if possible.
Flags: needinfo?(kgrandon)
Ok - I'll mark this as a 2.0? nom for being a dev workflow blocker.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
Keywords: regression
Can we bundle SystemAppProxy.jsm and other necessary components into non-production firefox builds? We did that in the past and that seemed to work well.
We already have a SystamAppProxy thing in browser helper.
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe]
It's a fun race. On desktop the gaia-grid component load and is ready before the app specific code has a change to add an event listener to initialize the rendering.

Shuffling files around fix it for me. I also need this patch pretty badly since I'm in an bug squashing event and this is the core dev env I want to promote. Due to the nature of the patch, r=me, and I will land once the try is green.
https://github.com/mozilla-b2g/gaia/commit/9d2e2b777c6f13a70f4ef3f6c5c759ad4531d01a
Assignee: nobody → 21
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8443882 [details] [diff] [review]
race.homescreen.on.nightly.patch

This is a relatively low risk patch that is needed for the vertical homescreen.
Attachment #8443882 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8443882 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Target Milestone: --- → 2.0 S5 (4july)
You need to log in before you can comment on or make changes to this bug.