Using socks proxy though SSH tunnel causes tunnel to disconnect with "Received data for nonexistent channel"

UNCONFIRMED
Unassigned

Status

()

Core
Networking
P3
normal
UNCONFIRMED
4 years ago
9 months ago

People

(Reporter: Brice Cox, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8442912 [details]
ssh.log.rtf

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Reproducible with Putty, SecureCRT under Windows7 and SSH on OSX 10.9.2
1. Build a SSH tunnel (ssh -D 8080 user@host -vvvv) ## Verbose output not needed to reproduce but gives additional data.
2. Configure Firefox to use socks proxy.  ## reproducible with socks 4 & 5 with or without DNS forwarding.
3. Load a site with high amount of threads.  ## www.whatismyip.com will reproduce almost every time.


Actual results:

1. Page loads in part
2. SSH session disconnected with error "Disconnecting: Received data for nonexistent channel" followed by a channel number.
3. From SSH logs it looks like Firefox is referencing a thread that it already closed.


Expected results:

SSH session should stay available and page should load.

Updated

2 years ago
Component: Untriaged → Networking
Product: Firefox → Core
Whiteboard: [necko-backlog]
You need to log in before you can comment on or make changes to this bug.