Closed Bug 1028069 Opened 5 years ago Closed 5 years ago

[Build System] Remove unused GAIA_SCHEME and GAIA_PORT from build system

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chens, Assigned: chens)

References

Details

Attachments

(1 file)

WIP
46 bytes, text/x-github-pull-request
yurenju
: review+
yurenju
: feedback+
Details | Review
Follow-up bug 1021481, after we have app protocol supported for DEBUG=1 mode, GAIA_SCHEME and GAIA_PORT is no longer required in build system utils to generate webapps related settings and should be removed.
Attached file WIP
Attachment #8443397 - Flags: feedback?(yurenju.mozilla)
This WIP involves build script changes in homescreen, ftu, and comms app. Should we invite app owners to take a look?
Comment on attachment 8443397 [details] [review]
WIP

you can just set review flag to me since that code was mostly wrote by me and George.
Attachment #8443397 - Flags: feedback?(yurenju.mozilla) → feedback+
Attachment #8443397 - Flags: review?(yurenju.mozilla)
Comment on attachment 8443397 [details] [review]
WIP

looks good, thank you!
Attachment #8443397 - Flags: review?(yurenju.mozilla) → review+
Merged to master 
https://github.com/mozilla-b2g/gaia/commit/1ff4200dbd8c6446c8b70df47c00ba5354d398bc
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Reopened because of regression in b2g-inbound.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
revert commit 
50e0c5489481b31522b8a08d3b9abf1e18da71e7
Merged to master
https://github.com/mozilla-b2g/gaia/commit/43fd8f8bff1f774cf5e9f9d8d3bbcfa2d4a30367
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Depends on: 1035640
You need to log in before you can comment on or make changes to this bug.