Closed Bug 1028378 Opened 8 years ago Closed 8 years ago

Changing runtime should disconnect the current one

Categories

(DevTools Graveyard :: WebIDE, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 34

People

(Reporter: jryans, Assigned: paul)

References

Details

Attachments

(1 file)

Maybe I am not understanding how the workflow is supposed to be...

But currently it seems like with WebIDE, you connect to a runtime from the runtime list, but if you want to disconnect and connect a new one, you have to first choose "Runtime -> Disconnect" from a menu.  If you try to instead choose a new runtime while already connected, you get a connection error.

Shouldn't we just disconnect if you choose a new runtime when already connected?
Attached patch v1Splinter Review
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #8465324 - Flags: review?(jryans)
Duplicate of this bug: 1046760
Comment on attachment 8465324 [details] [diff] [review]
v1

Review of attachment 8465324 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, seems to work well! :D
Attachment #8465324 - Flags: review?(jryans) → review+
https://hg.mozilla.org/mozilla-central/rev/8a0d350282a6
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Duplicate of this bug: 938570
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.