"Save Page as ..." an Internet page

RESOLVED DUPLICATE of bug 18764

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 18764
4 years ago
4 years ago

People

(Reporter: evanmous, Unassigned)

Tracking

30 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

I clicked on File>Save Page as (OS: Windows XP)...


Actual results:

A folder and an .htm file (icon)were saved to the desktop, for instance.  Clicking on the latter would take me to the desired Firefox page.


Expected results:

I would have preferred to see the page saved the way IE is doing it with a single icon.

Comment 1

4 years ago
What is "the way IE is doing it with a single icon"?
Flags: needinfo?(evanmous)
(Reporter)

Comment 2

4 years ago
After you click on File>Save As..., you specify where the desired Web page should be saved (let's say, the Desktop)and click on "OK".  Then, an icon appears, like a shortcut, on the Desktop.  Later on, when you click on this icon, it takes you to desired Web page.

Firefox, on the other hand, produces an icon plus a related folder.  Can you eliminate this folder, the way Internet Explorer does?
Flags: needinfo?(evanmous)

Comment 3

4 years ago
I believe that this is a request for mht support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 18764
(Reporter)

Comment 4

4 years ago
Personally, I don't see any connection between my bug 1028603 and bug 18764. Does the fix to the latter bug produce a single icon without the related folder?  Not in my case.

Comment 5

4 years ago
(In reply to evanmous from comment #4)
> Personally, I don't see any connection between my bug 1028603 and bug 18764.
> Does the fix to the latter bug produce a single icon without the related
> folder?  Not in my case.

If bug 18764 was fixed, you (or the browser) could combine and save all files of a web page (images, styles, html etc.) as a single .mht file. No folder (including those files separately) would be necessary.
That's probably what you see here.
(Reporter)

Comment 6

4 years ago
Under these circumstances (such a folder is necessary, in my case), bug 18764 was not fixed, as far as I am concerned!

Evanmous

Comment 7

4 years ago
> bug 18764 was not fixed

It's obviously not fixed, otherwise it's status field would show "FIXED" rather than "NEW".

Btw, there are Firefox extensions to solve your problem:
https://addons.mozilla.org/en-US/firefox/addon/unmht/
https://addons.mozilla.org/en-US/firefox/addon/mozilla-archive-format/
You need to log in before you can comment on or make changes to this bug.