Closed Bug 1028674 Opened 5 years ago Closed 5 years ago

[Collection app] Generated icon shows duplicate apps

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: ranbena, Assigned: amirn)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files)

Smart Collection icons are generated with icons from the 3 first apps in the SC.
Deduped apps aren't taken into account, therefore duplicate apps appear in the generated icon.

Attached screenshot of the following STR:
1. Install "Around Me" SC and open it.
2. There are no pinned apps. Pin the first 2 web results.
3. Swap they're positions (drag and drop)
4. Return to homescreen and observe the SC icon

Expected: The 3 first web results appear in the icon.
Actual: The second result appears twice in the icon.

(Note that the web results in the screenshot would differ depending on device location)
Attached file Screen cast
Attached image Screenshot.jpg
Blocks: vertical-home-next
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Assignee: nobody → amirn
Attached file Pull Request
didn't change dedupe.js after all :)
Attachment #8455306 - Flags: review?(kgrandon)
Comment on attachment 8455306 [details] [review]
Pull Request

Seems fine to me, thanks!
Attachment #8455306 - Flags: review?(kgrandon) → review+
Do we want this bug fixed in 2.0?
Flags: needinfo?(anygregor)
Whiteboard: [systemsfe]
Amir, do you want to ask for uplift? Seems like a minor bug.
Flags: needinfo?(anygregor) → needinfo?(amirn)
Comment on attachment 8455306 [details] [review]
Pull Request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Never implemented
[User impact] if declined: Will show duplicate apps in Collection icon
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: deduped icons
Attachment #8455306 - Flags: approval-gaia-v2.0?
Flags: needinfo?(amirn)
Attachment #8455306 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Attached video VIDEO0106_Compress.MP4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.