Closed Bug 1028710 Opened 6 years ago Closed 6 years ago

Flickering of views during transition on opening a New Private Tab when tab drawer open and on tab drawer open/close animation

Categories

(Firefox for Android :: General, defect)

33 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 33
Tracking Status
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox33 --- verified
fennec + ---

People

(Reporter: aaronmt, Assigned: lucasr)

References

()

Details

Attachments

(4 files)

Attached image Frame screenshot #1
Not a new issue.

Currently on New Private Tab there when the tab drawer is open there is a flickering of views in the UI when the tab bar rolls up. This doesn't happen at all with normal tabs.

We need to make sure that there is a proper view shown during the animation and transition.

I see this on my Galaxy S5 and Nexus 5 and other devices.

Video: https://www.youtube.com/watch?v=igEmgbkJ8Tk
Attached image Frame screenshot #2
See video of the transition on my Galaxy S5. At the end of the day the transition looks like something is broken as the flicker between views is shown.

Video: https://www.youtube.com/watch?v=igEmgbkJ8Tk
Perhaps also emphasized with the New Private Tab placeholder text and graphic taking longer to load and appear. I wonder if that resource loading can be improved?
This also is visible on simply opening and closing the tab drawer on the Private Tab pane.

See second video: https://www.youtube.com/watch?v=WvW1A2vvFqo
Summary: Flickering of views during transition on opening a New Private Tab when tab drawer open → Flickering of views during transition on opening a New Private Tab when tab drawer open and on tab drawer open/close animation
Ian - Thoughts
tracking-fennec: ? → +
Flags: needinfo?(ibarlow)
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Ian - Thoughts

What kind of feedback are you asking for? I definitely agree that the views should not flicker when the tab tray opens and closes.
Flags: needinfo?(ibarlow)
I suspect this is caused by the fact that the LayerView's background doesn't match the private tab's darker color.
Comment on attachment 8449330 [details] [diff] [review]
Set overscroll color based on tab type (r=bnicholson)

Overscroll color can be seen when we open/close the tabs tray. Make it account for the type of tab being selected (normal or private).
Attachment #8449330 - Flags: review?(bnicholson)
Comment on attachment 8449331 [details] [diff] [review]
Init private tab bg color to avoid flickering (r=bnicholson)

Init new private tabs with proper background color.
Attachment #8449331 - Flags: review?(bnicholson)
Assignee: nobody → lucasr.at.mozilla
Comment on attachment 8449330 [details] [diff] [review]
Set overscroll color based on tab type (r=bnicholson)

Easy enough to steal while Brian is on PTO
Attachment #8449330 - Flags: review?(bnicholson) → review+
Attachment #8449331 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/0a020e033338
https://hg.mozilla.org/mozilla-central/rev/9e5e9a282e0c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Verified as fixed in build:
Firefox for Android 33.0a1 (2014-07-04)

Devices:
Samsung S3 (Android 4.3)
Asus Transformer Pad TF300T (Android 4.2.1)
Motorola Razr (Android 4.0.4)
This seems related to Bug 1031872, which has a nice slomo video. Lucas, do you have an opinion on that bug?
(In reply to Richard Newman [:rnewman] from comment #16)
> This seems related to Bug 1031872, which has a nice slomo video. Lucas, do
> you have an opinion on that bug?

Seems unrelated. Added a comment there.
You need to log in before you can comment on or make changes to this bug.