FirefFirefox becomes unusable when attempting to print while "Unresponsive Script" is displayed for pdf.js

RESOLVED DUPLICATE of bug 476541

Status

()

RESOLVED DUPLICATE of bug 476541
5 years ago
5 years ago

People

(Reporter: rainer-bugzilla, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Display a .pdf that renders slowly

Open the Print dialog via the printer button in the PDF toolbar

the "Unresponsive Script" Dialog opens in the background

Select "Print" or "Cancel" in the Print dialog


Actual results:

The Print dialog does not close, it is not possible to interact with the  "Unresponsive Script" dialog or any other Firefox window. Quit does not work; "Force Quit" or kill appear to be the only way to escape this deadlock.

I'm using Firefox  30.0 on MacOS 10.8.5. I have been unable to reproduce this, since I don't get the Unresponsive Script message anymore.


Expected results:

No deadlock.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
QA Whiteboard: [bugday-20140630]
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.